XSLT not working when server does not send correct content-type for the .xsl file

RESOLVED INVALID

Status

()

Core
XSLT
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Shlomi Fish, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

When viewing an .xml file with an XSLT stylesheet specified, it is not working
if the server does not send a correct content-type for the XSLT. In our example
the server sent application/octet-stream for the g.xsl file. OTOH, in the file:

http://www.iglu.org.il/shlomif/Mozilla-Bugs/xslt-content-type/good/g.xml

I configured the web-server to send text/xml for the XSLT file and it is 
viewed correctly. This is despite the fact that the xml-stylesheet directive
contains a type="text/xml" specifier.

Reproducible: Always

Steps to Reproduce:
1. Access http://www.iglu.org.il/shlomif/Mozilla-Bugs/xslt-content-type/g.xml


Actual Results:  
I saw a blank screen

Expected Results:  
Render the XML after it was processed by the g.xsl XSLT stylesheet.
This is by design. You have to send the correct contenttype from the server.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.