Cannot enter name for Phonebook search

VERIFIED DUPLICATE of bug 20148

Status

()

Core
Editor
P3
major
VERIFIED DUPLICATE of bug 20148
19 years ago
17 years ago

People

(Reporter: Peter Trudelle, Assigned: buster)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
Today's opt NS bits.
Go to internal phonebook URL.
Click in Name text field.
Cursor turns to ibeam, but no caret.
Try to type.
nuttin' happens.
Other text fields seem to work okay. (I filed this bug using same bits).

Updated

19 years ago
Assignee: beppe → buster
Target Milestone: M12

Comment 1

19 years ago
Kin and I did a prelim and I think it has something to do with the .js file. If
you make a local copy and point to the .js file, it won't work. If you remove
the pointer to the .js file, it works fine. Steve, can you give this a look?

Comment 2

19 years ago
here is the associated .js data:
function goToURL(i){
window.location.href=i;
}

function easter(){
if (document.forms[0].searchstringie.value=='worker and parasite'){
    window.open
("../html-pb/worker.qt","worker","scrollbars=no,menubar=no,resizable=no,width=30
0,height=300");
               }
if (document.forms[0].searchstringie.value=='buttmonkey'){
    window.open
("../html-pb/reeeee.au","leif","scrollbars=no,menubar=no,resizable=no,width=200,
height=200");
               }
if (document.forms[0].searchstringie.value=='pbteam'){
    window.open
("../html-pb/team.jpg","leif","scrollbars=no,menubar=no,resizable=no,width=350,h
eight=220");
               }
}


function flipImg(currImg,newImg) {
        document.images[currImg].src = newImg;
}

function fieldFocus(){
setTimeout("document.forms[0].searchstringie.focus()",400);
}

function checkForNullString(){
if (document.forms[0].searchstringie.value != "")
  {
    return true;
  }
else
  {
    window.open
("../html-pb/nullStringError.html","leif","scrollbars=no,menubar=no,resizable=no
,width=400,height=250");
    parent.resultframe.location="../html-pb/nullStringError.html";
    return false;
  }
}

function AllConference(){
document.forms[0].searchstring.value = document.forms[0].searchstringie.value;

if (document.forms[0].searchstring.value=='*' &&
document.forms[0].type[document.forms[0].type.selectedIndex].text=="Conference
Rooms"){
        document.forms[0].searchstring.value="cn=*";
        }
}
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

19 years ago
this is a dup of saari's bug 20148.  see that bug for details.  probably worth a
quick phone call to me before spending time on text control - specific bugs so
duplicate effort doesn't occur.

*** This bug has been marked as a duplicate of 20148 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
verified in 12/1 build.
You need to log in before you can comment on or make changes to this bug.