All users were logged out of Bugzilla on October 13th, 2018

pages with an invalid charset should result in notification to the user

VERIFIED WONTFIX

Status

()

--
enhancement
VERIFIED WONTFIX
16 years ago
12 years ago

People

(Reporter: miken32, Assigned: smontagu)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

If a page specifies an invalid charset (the URI above specifies "x-euc") the
browser defaults to intl.charset.default.  This is good behaviour for a site
where *no* charset is specified.  But I think if an *invalid* charset is
specified, the user should be given the opportunity to choose another charset,
based on the invalid name.  i.e. the example page could suggest euc-jp because
it's the most similar name.
Maybe a status bar icon would be good for this?  I wouldn't suggest a dialog
box, that would be too intrusive.

Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
If you turn on the auto-detector, go to View | Character Coding | Auto-detect,
select Universal or Japanese, you will get the page display properly.

Also you can manually select your own charset by go to View | Character Coding |
More | East Asian | Japanese (EUC-JP) to get the page display correctly.
(Reporter)

Comment 2

16 years ago
I've enabled the "Univeral" auto-detect on my profile for the last few days, and
have been having a few problems with it.  for example, looking at bug 195280, I
get it using what looks like one of the Asian fonts, and it reports an encoding
of "gb18030" in page info.  But other pages (like this one) at b.m.o show up fine!

Comment 3

16 years ago
Please clear the Cache (Edit | Preferences | Advanced ), re-launch the browser,
then should be fine.

Basically the problem discribed in this bug we can say it's worksforme. 

Comment 4

15 years ago
Works for me using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7a)
Gecko/20040207

Marking WFM.
Reporter, please reopen if you still see this in a current build. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 5

15 years ago
What do you mean by 'work for me'? This bug (as originally filed) was an
enhancment request. If Mozilla doesn't understand MIME charset specified, the
reporter thinks that there should be an indication of sort. If this has to be
resolved, it has to be resolved as 'WONTFIX'. Otherwise, it should be left open.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 6

14 years ago
Michael Newton:  

Re: comment 5, do you wish to keep open this request for notification of an 
invalid charset?  If not, please close this bug by marking it   Resolved|WontFix

In my opinion, such an option is unnecessary and would even be annoying; far 
better to get autodetection working as well as possible (and there are multiple 
bugs about that feature).

Re: your comment 2: that particular symptom is bug 181344.
(Reporter)

Comment 7

14 years ago
I agree that auto-detection should be as good as possible, but thought a warning
icon might be useful so you know when the auto-detect code has made a guess, and
might have guessed incorrectly.
However, if the developers are disinclined to fix this, I will mark it WONTFIX
shortly.
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/
(Reporter)

Updated

13 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago13 years ago
Resolution: --- → WONTFIX

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.