Compile error in nsTHashtable.h

RESOLVED DUPLICATE of bug 201407

Status

()

Core
XPCOM
RESOLVED DUPLICATE of bug 201407
15 years ago
15 years ago

People

(Reporter: Kishan Thomas, Assigned: Benjamin Smedberg)

Tracking

Trunk
HP
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4b) Gecko/20030506
Build Identifier: Mozilla/5.0 (X11; U; HP-UX 9000/785; en-US; rv:1.4b) Gecko/20030506

With 1.4b trunk build on HP-UX with aCC compilers, hitting the following compile
error:

while compiling mozilla/xpcom/ds/nsTHashtable.cpp

Error 172:
"/tmp_mnt/proj/client_java/mozilla/NIGHTLY/BUILD/PA-java05-Tue-May--6-230659-PDT-2003-nopatch/mozilla/xpcom/ds/nsTHashta
ble.h", line 234 # Undeclared variable 'PL_DHashStubEnumRemove'.
        PL_DHashTableEnumerate(&mTable, PL_DHashStubEnumRemove, nsnull);

Compile error goes away on moving PL_DHashStubEnumRemove definition to the top
of file before nsTHashtable class.



Reproducible: Always

Steps to Reproduce:
(Reporter)

Updated

15 years ago
Summary: Compile error in nsTHashtable.h → Compile error in nsTHashtable.h
Build problems that are traceable to specific code should filed against that
component, not Build Config.
Assignee: mozbugs-build → dougt
Component: Build Config → XPCOM
QA Contact: granrose → scc
hashtables -> bsmedberg
Assignee: dougt → bsmedberg
(Assignee)

Comment 3

15 years ago
This is a similar problem, if not exactly the same, as bug 201407. Marking
duplicate. I have a patch with r/sr/a there, but it breaks older stupid
compilers that don't like the C++ "using" directive.

*** This bug has been marked as a duplicate of 201407 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.