Characters not displayed correctly on rediff

RESOLVED WONTFIX

Status

Tech Evangelism Graveyard
English Other
RESOLVED WONTFIX
15 years ago
3 years ago

People

(Reporter: S K Bhachech, Unassigned)

Tracking

Details

(Whiteboard: [gujarati] [dynamic font], URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4a) Gecko/20030401

Rediff.com tries to use it's own TrueType fonts to display text in Gujarati
language, but fails to display may of the characters correctly. They are
replaced by '$', '?' and '>' characters. (If you are looking at the page, rest
assured that any given word in Gujarati is not going to have '$', '?' or '>' in
the middle of it.)

The same page is displayed perfectly in (*sigh*) IE.


Reproducible: Always

Steps to Reproduce:
1. Goto http://www.rediff.com/gujarati/
2. Look at the faulty characters.
3. Click on any link on that and subsequent pages, so long as you are within the
gujarati subdirectory.
4. Same results on those pages as well.

Actual Results:  
Even after downloading and installing the fonts, problem remains. In fact, the
TTFs don't even have a character $, yet it shows up on the page. Strange!

Expected Results:  
Characters such as ¡, Þ should have displayed instead of ?.

Updated

15 years ago
QA Contact: ruixu → momoi

Comment 1

15 years ago
This Guajarati site uses embedded font technology -- TrueDoc Dynamic 
Font for Netscape Comm 4.x and WEFT for IE4/5/6. Both technologies 
provide portable fonts on the site for browsers to use. 

Such a technology was supported in Comm 4.x but not with Mozilla
development. The site also understands this situation and provides
this note:

http://www.rediff.com/gujarati/help.htm

We have two options:

1. File an RFE bug for Mozilla to support Dynamic Fonts. Since Bitstream
   no longer is working on TrueDoc, this is unlikely.
2. Ask the site to switch to Unicode and stop using embedded font
   technologies.

I don't think we will be successful with either options. The site knows
the limitation for Mozilla and still wants to use this technology.

I am inclined to resolve this bug as Wontfix.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

15 years ago
Here's the .js file that defines dynamic fonts for Comm 4.x and
IE 5/6.

http://www.rediff.com/gujarati/fonts26.js

Moving to English-Other.
Assignee: momoi → english-other
Component: Asian → English Other
QA Contact: momoi → english-other
Whiteboard: [gujarati] [dynamic font]

Comment 3

15 years ago
The site will not make chanegs to their dynamic font use.
Either Mozilla will have to support it or wait until
most sites will switch to Unicode. 

Resolving it as Wontfix. Please file an RFE bug for Mozilla
for dynamic font technology.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.