If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Automatic proxy scripts are broken with Mozilla 1.4b

RESOLVED WORKSFORME

Status

()

Core
Networking
--
major
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Stephen Bounds, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030506
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030506

Using an automatic proxy configuration URL is broken with Mozilla 1.4b.  That
is, all web pages refuse to load

Using a build from a few days ago, eg. 2003050610, this problem does not exist.

Reproducible: Always

Steps to Reproduce:
1. Edit -> Preferences -> Proxies
2. Set to browse the Internet using an automatic proxy configuration URL
3. Attempt to load any web page (eg. www.google.com).

Actual Results:  
The web page does not load.

Expected Results:  
The web page should load as normal.

Manual proxies seem to still be working, eg.

4. Edit -> Preferences -> Proxies
5. Set to browse the Internet using manual proxy configuration.
6. Load any web page (eg. www.google.com).  This will work!

Comment 1

15 years ago
Reporter, can you post your PAC-file ? You can edit out private stuff if you like.
(Reporter)

Comment 2

15 years ago
See proxy.pac below.  Note that I have removed any identifying features as
suggested.
====

function FindProxyForURL(url, host)
{
  // Anything starting with these URLs is part of our intranet
  if (url.substring(0, 14) == "http://intran1" ||
      url.substring(0, 14) == "http://intran2") {
    return "DIRECT";
  }
  // These IP ranges are part of our intranet
  // (changed to random values)
  else if (isInNet(host, "215.34.63.0", "255.255.255.0")) {
    return "DIRECT";
  }
  else if (isInNet(host, "96.43.156.0", "255.255.255.0")) {
    return "DIRECT";
  }
  else if (isInNet(host, "112.45.56.0", "255.255.255.0")) {
    return "DIRECT";
  }
  // use these proxy servers for http URLS
  else if (url.substring(0, 5) == "http:") {
    return "PROXY local-proxy.our.organisation.com:8080; PROXY
wan-proxy.our.organisation.com:8080";
  }
  // use these proxy servers for ftp URLS
  else if (url.substring(0, 4) == "ftp:") {
    return "PROXY local-proxy.our.organisation.com:8080; PROXY
wan-proxy.our.organisation.com:8080";
  }
  // use these proxy servers for gopher URLS
  else if (url.substring(0, 7) == "gopher:") {
    return "PROXY local-proxy.our.organisation.com:8080; PROXY
gopher-wan-proxy.our.organisation.com:8080";
  }
  // use these proxy servers for all other URLS
  else {
    return "PROXY wan-proxy.our.organisation.com:8080; DIRECT";
  }
}

Comment 3

15 years ago
I am also seeing this problem on the 1.4b release on Windows NT.  Using a packet
snooping program indicates that Mozilla is never even attempting to load the
PAC file - it just starts trying to download the start page.

I have the same configuration on Linux 1.4b and do *not* see this problem there.
(Assignee)

Comment 4

15 years ago
WORKSFORME win2k 2003050908 trunk.  please reopen if the problem still exists
with a more recent build.  also, could you please try creating a simpler PAC
file (if the problem still exists)?  thanks! 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
and be sure that you install in a complete empty directory and not over older build.
(Reporter)

Comment 6

15 years ago
My apologies, installing into an empty directory fixes the problem.  Thanks for
the suggestion Matti.

Comment 7

15 years ago
*** Bug 205402 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.