After fresh install of mozilla get an Entry Point Not Found error when starting mozilla

RESOLVED DUPLICATE of bug 202326

Status

Core Graveyard
Embedding: GRE Core
RESOLVED DUPLICATE of bug 202326
15 years ago
a year ago

People

(Reporter: Don, Assigned: dougt)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

After a fresh install (Windows 2000 server), the following error is encountered
when Mozilla is started (quicklaunch disabled):

Entry Point Not Found

The procedure entry point NSS_CMSMessage_IsSigned could not be located in the
dynamic link library smime3.dll.



Reproducible: Always

Steps to Reproduce:
1. Install Mozilla 1.4b 
2. Load Mozilla
3. Uninstall, repeat

Actual Results:  
Get the entry point not found error

Expected Results:  
Loaded with no errors

Comment 1

15 years ago
This is a known problem.  We plan to fix it in Mozilla
1.4 final.

The problem is caused by older NSS DLLs (nss3.dll,
smime3.dll, and ssl3.dll) in your system directory.
Can you look in C:\WINNT\system32 or C:\WINDOWS\system32
for these three DLLs?  Do you have Netscape Directory
Server installed on your system?
Assignee: wtc → dougt
Status: UNCONFIRMED → NEW
Component: Libraries → Embedding: GRE Core
Ever confirmed: true
Product: NSS → Browser
QA Contact: bishakhabanerjee → ashishbhatt
Version: unspecified → Trunk

Comment 2

15 years ago
Have experienced same problem on machine that only has the Netscape/iPlanet
Console (i.e. 5.1) installed.  Does a work-around to this problem exist?
(Reporter)

Comment 3

15 years ago
The versions of nss3.dll, smime3.dll and ssl3.dll are all 3.3.1.0.  Netscape 
directory server isn't installed, but iPlanet and another LDAP server are 
installed.


Comment 4

15 years ago
The work around is to copy the following four DLLs:
    nss3.dll
    softokn3.dll
    smime3.dll
    ssl3.dll
from the GRE directory (which looks like
C:\Program Files\Common Files\mozilla.org\GRE\<version-build-date-id>)
to the Mozilla directory (the directory where mozilla.exe resides).
(Assignee)

Comment 5

15 years ago
This is a duplicate of 202326.

*** This bug has been marked as a duplicate of 202326 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.