mailto: link in message pane should use current account's identity for message compose format

RESOLVED DUPLICATE of bug 194809

Status

MailNews Core
Networking: POP
RESOLVED DUPLICATE of bug 194809
15 years ago
9 years ago

People

(Reporter: Sean Su, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

15 years ago
The mailto: links that show up in the message pane currently use the default
account's identity to determine the message compose format to open.

It should be using the identity from the account that the message is in.

to reproduce:
1) run mozilla mail
2) make sure there's at least 2 accounts
3) make sure account #1 is set to compose new messages in PlainText mode
4) make sure account #2 is set to compose new messages in HTML mode
5) open a message in account #2 that has an email address in the message pane.
6) click on the email address.

Notice that this brings up the mail compose window in PlainText mode.  It should
be bringing it up in HTML mode.
format is important, but I think getting the right identity is equally important.

I think the fix for this will be to mailWindow.js, see messagePaneOnClick()

if the url has a scheme of mailto, we have to jump in, and handle it, and set
the identity for the compose window.

note to scott, thunderbird has forked mailWindow.js, so you won't be able to
take advantage of this fix directly.

Comment 2

15 years ago
*** Bug 176738 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
*** Bug 194809 has been marked as a duplicate of this bug. ***
Bug #194809 is not a dupe of this.
Bug #190120 solved the bug #194809
Reporter: please mark this bug as a dupe of bug #194809 , created 2 months
earlier. Thanks.

Comment 6

15 years ago
This bug is a sub-symptom of bug 194809, and I don't think it really needs its
own bug. 

*** This bug has been marked as a duplicate of 194809 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.