Closed Bug 204944 Opened 19 years ago Closed 17 years ago

Sidebar History >View not keyboard accessible

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

RESOLVED FIXED

People

(Reporter: Lil46john, Assigned: doronr)

References

(Blocks 1 open bug)

Details

(Keywords: access, helpwanted)

Attachments

(2 files, 4 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

IE has one. Maybe since people want one for Search Bar icon, they would want one
for View.

Reproducible: Always

Steps to Reproduce:
1. Go to History
2. Look at View
3.

Actual Results:  
Want to change it with keyboard(not really) but can't

Expected Results:  
Have an accesskey for it
Blocks: firekey
Summary: No accesskey in History sidebar for View → needs accelerator key for History>View
Confirming
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: needs accelerator key for History>View → needs keyboard accelerator for Sidebar History >View
IMO this WONTFIX or INVALID. We have keyboard accelerators for all the view
options in the history sidebar. Why would we need an accelerator for View?
QA Contact: asa → mozilla
"Why would we need an accelerator for View?" 
-- Well, at least on my build, I can't get to the "View" menu with just the
keyboard.

I vote to use IE's shortcut of Alt+W, that won't cause a clash as far as I can see.
Problem:  What if the HTML content in the active frame has a field that uses the
accesskey of "w" already? (.e.g. <input name="status_whiteboard" accesskey="w"
value="" size="60">).  Try ALT-W on this page and see what happens.  Oops, I'm
using 0.8 on this computer.  I hope this is the same on 0.9.3 (upgrading after
this submit! :)
Keywords: access
*** Bug 256233 has been marked as a duplicate of this bug. ***
Please put the View button in the tab order and make sure it shows focus and the
Enter key can open it. Looks like a "button with popup" control, which should
act that way.
Keywords: sec508
Priority: -- → P3
Summary: needs keyboard accelerator for Sidebar History >View → Sidebar History >View needs mnemonic key and should be in tab order
What happened with this patch. Why was it never submitted for review?
Keywords: helpwanted
Flags: blocking-aviary1.1?
Priority: P3 → P2
Jeeds mnemonic key and should be in tab order
Severity: enhancement → normal
Summary: Sidebar History >View needs mnemonic key and should be in tab order → Sidebar History >View not keyboard accessible
aaron -  when focused, enter does not show the dropdown.  This could be
something wrong in the core.
Flags: blocking-aviary1.1? → blocking-aviary1.1+
(In reply to comment #10)
Whatever widget it is, the implementation in XBL must be fixed so that both
Enter and space drop down the menu.
Comment on attachment 174407 [details] [diff] [review]
patch - however, when focused, enter does not show the dropdown.

This should be a button, not a toolbarbutton, because it's not in the toolbar.
Toolbar buttons are not focusable.

If there is no binding yet for button type="menu" there should be.

The following 3 ways should open the dropdown:
enter, space and the accesskey.

There should definitely be an accesskey assigned,alt+W would be okay.
Attached patch patch v1 (obsolete) — Splinter Review
Assignee: firefox → doronr
Attachment #174407 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #178855 - Flags: superreview?(neil.parkwaycc.co.uk)
Comment on attachment 178855 [details] [diff] [review]
patch v1

>+    <handlers>
>+      <handler event="keypress">
>+      <![CDATA[
>+        if (event.keyCode == event.DOM_VK_RETURN ||
>+            event.charCode == event.DOM_VK_SPACE) {
>+          this.open = true;
>+        }
>+      ]]>
>+      </handler>
>+    </handlers>
Two questions:
1. Why enter and space? Which native widgets are we copying?
2. Would you mind writing a separate <handler/> for each key?
> 1. Why enter and space? Which native widgets are we copying?
I told him to do that. Buttons that contain popups are not very common, but I
have seen them. Because they are buttons, they still are activated the way
normal buttons do: via Enter, space or the mnemomonic accesskey.

Attachment #178855 - Attachment is obsolete: true
Attachment #178855 - Flags: superreview?(neil.parkwaycc.co.uk)
Attached patch with neil's nits (obsolete) — Splinter Review
In gnomestripe, we default to giving a min-width to buttons, but in the sidebar
this is ugly (causes a really short input field).  Hence the
style="min-width:0px !important;" on the button.

Also, this patch fixes menu buttons in firefox from displaying a whole column
of dropdown arrows (probably related to the min-width) by adding:
  background-repeat: no-repeat;
  background-position: center center;
Attachment #179060 - Flags: superreview?(neil.parkwaycc.co.uk)
Attached patch with neil's nits (obsolete) — Splinter Review
In gnomestripe, we default to giving a min-width to buttons, but in the sidebar
this is ugly (causes a really short input field).  Hence the
style="min-width:0px !important;" on the button.

Also, this patch fixes menu buttons in firefox from displaying a whole column
of dropdown arrows (probably related to the min-width) by adding:
  background-repeat: no-repeat;
  background-position: center center;
Attachment #179061 - Flags: superreview?(neil.parkwaycc.co.uk)
Comment on attachment 179060 [details] [diff] [review]
with neil's nits

weird, double post somehow.
Attachment #179060 - Attachment is obsolete: true
Attachment #179060 - Flags: superreview?(neil.parkwaycc.co.uk)
Attachment #179061 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview-
Attachment #179061 - Attachment is obsolete: true
Attachment #179106 - Flags: superreview?(neil.parkwaycc.co.uk)
Comment on attachment 179106 [details] [diff] [review]
update xpfe, use action=""

>+      <handler event="keypress" keycode="VK_RETURN" action="this.open = true"/>
>+      <handler event="keypress" key=" " action="this.open = true"/>
Nit: semicolons please.
Attachment #179106 - Flags: superreview?(neil.parkwaycc.co.uk) → superreview+
checked in.
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Could this patch have caused bug 288662?
The button looks ugly since the button class is now toobarbutton.
See attachment 179296 [details] for the old look.
Isn't it possible to get it back with or without keeping the actual class ?
Component: History → Bookmarks & History
QA Contact: mozilla → bookmarks
You need to log in before you can comment on or make changes to this bug.