Add support for CSS extensions found in IE 5/6.

RESOLVED DUPLICATE of bug 77790

Status

()

Core
Layout
--
enhancement
RESOLVED DUPLICATE of bug 77790
15 years ago
15 years ago

People

(Reporter: M. LaPlante, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

Internet Explorer 6 supports a few popular extensions to CSS.  Primarily, I'm
focusing on the scrollbar extension, allowing designers to alter the appearance
of page scrollbars in the browser.  A reference to these extensions can be found
here:
http://msdn.microsoft.com/library/default.asp?url=/workshop/author/css/reference/attributes.asp

I know some dev will probably throw this back in my face because the extensions
aren't in the W3C spec.  My argument is this:  Surf around with IE for awhile,
and you'll see extensions like these in use all over the web.  The scrollbars
seem to be particularly popular with web designers.  If you want to compete with
a browser like IE, you have to give the users what they want to see!  Mozilla
has great potential, but if you stick so tightly to spec that you deny users
these little types of bonuses, they'll go with the more flexible IE every time.
 Even if you don't want to "copy" Microsoft's features, you need to give the
designers some way of achieving the looks they want...locking them into a hard
specification won't make many new fans.  Thanks.

Reproducible: Always

Steps to Reproduce:
NA
Actual Results:  
NA

Expected Results:  
NA

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 77790 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.