when composing a new HTML email, links are generated from different strings.

VERIFIED DUPLICATE of bug 183111

Status

MailNews Core
Composition
VERIFIED DUPLICATE of bug 183111
15 years ago
10 years ago

People

(Reporter: ed, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

If a new email is written, and sent as an HTML, and a section of the mail is
like foo:bar, the whole section of the mail is turned into a link.

The HTML parser seems to link that foo: indicates the start of a link in the
same way as mailto:

This occurs with any string as the prefix. (i.e blah:)

The same issue occurs when viewing a plain text email sent with a section in the
format described above.

I can't see a way to workaround this.

Reproducible: Always

Steps to Reproduce:
1. Create new email, and type foo:bar
2. Send the email to any recipient in HTML format
3. View the received email in any email client, where foo:bar is turned into <a
class="moz-txt-link-freetext" href="foo:bar">foo:bar</a> in the source.

Actual Results:  
The text was displayed as a link, despite not being a valid format for a link.

Expected Results:  
The text should have been identified as not being a valid link, and have been
displayed as text.

Comment 1

15 years ago
Fixed in 1.4a. Please use a recent nightly build when trying to reproduce bugs.

*** This bug has been marked as a duplicate of 183111 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 2

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.