Tooltip (title tip) for truncated subject line blocks mouse click

RESOLVED DUPLICATE of bug 200234

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 200234
15 years ago
13 years ago

People

(Reporter: Joseph Delaney, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030509
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030509

When you receive a message with a long subject line that cannot be displayed
fully in the message list, hovering your mouse over the message will pop up a
tooltip with the full subject line. It is positioned exactly under the mouse
pointer, and interferes with the mouse click. In order to click or double-click
on the message, you need to wait for the tooltip to disappear or move the mouse
away and back again. This is aggravated by the fact that the tooltips pop up
much too quickly (for my taste), and I often position the mouse over the subject
line that I am reading as I decide whether I want to click or not.  

In the browser, the tooltips are offset so that they appear below the bottom of
the cursor rather than directly under the active point. This bug can be viewed
either as mailnews tooltips not having the same offset as the browser, or that
the tooltip does not pass the mouse click on to the item underneath it.

Reproducible: Always

Steps to Reproduce:
1. Send yourself a message with a very long subject line
2. Check your mail so the message is now in your inbox.
3. Position your mouse over the message subject so that the tooltip appears
4. Before the tooltip disappears, try to click or double click the message.

Actual Results:  
Nothing happens - the click is blocked by the tooltip.

Expected Results:  
Clicking or double-clicking should select or open the message.

Comment 1

15 years ago
Heh, let me guess: Pinstripe theme, right? If so, dup of bug 200234.
(Reporter)

Comment 2

15 years ago
Nice catch. I'm not using Pinstripe, but I am using Orbit3+1. When I switch to
Modern the bug is gone.
(Reporter)

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 200234 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.