When adding the item to the popup window the window tries to finish the order rather then allowing me to add more items.

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Matt, Assigned: asa)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

Its a order system for my work.  It works with barcodes, add items and a box
pops up where you start scanning items, normally, you can barcode scan as many
items as you need, then click add to order and then it asks for details on
shipping.  Well in mozilla (windows or linux) you add the first item (barcode or
numpad) it doesnt add the item and takes you to the shipping info.  I know very
little of html and the like, so I hope I'm not repeating a bug.

Reproducible: Always

Steps to Reproduce:
1.enter my account info
2.click on place an order
3.add any item to my list

Actual Results:  
it doesnt add the item and tries to end the order session

Expected Results:  
added the item and allowed me to add more.

I've been able to reproduce this bug under any situation.  Win98/ME/XP.  Linux
RedHat 8.0/9.0.  FreeBSD.  SLack9.  Any theme.

Comment 1

15 years ago
You might post the HTML source for the page, since it sounds like either their
programming or Mozilla is improperly processing the carriage return from the
scanner (I'm assuming that's what the scanner does after outputting the
barcode).  Perhaps they're not using Mozilla's event.stopPropagation method to
prevent the keypress from bubbling up to the form.
(Reporter)

Comment 2

15 years ago
Well, I talked to the owners of the site and they gave me a test login and
password so that it can be tested.  If you want to see the bug in action go
ahead and email me and I will send you the username and password.

Comment 3

14 years ago
Hi Matt, are you still having problems with this barcode scanning software and
Mozilla? If newer builds are still demonstrating the bug, then yes, having a
test account on the site would be helpful in tracking down the problem. Thanks
for any new information.

Comment 4

14 years ago
Closing bug as worksforme, it's been more than 6 months without further comment.
If you still have problems with recent builds of Mozilla on your website, please
feel free to reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.