Mozilla 1.4b or 1.4rc3 built with GCC 3.3 does not start on Solaris8

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
blocker
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Nicolas Pioch, Assigned: asa)

Tracking

Trunk
Sun
Solaris

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.3) Gecko/20030314

Building Mozilla/1.4b exactly the same way as usual... read
  ftp://depot.mcom.com/pub/pioch/mozilla-1.4b/README
for full details

Whereas it always worked for previous releases (since 1.2a), it doesn't anymore:
at startup, mozilla creates
  components/compreg.dat
  components/xpti.dat

but then exits and never creates
  chrome/chrome.rdf
  chrome/overlayinfo/

Debugging with:
export NSPR_LOG_MODULES=all:5

finishes with:

1[65c90]: NPN Logging Active!
1[65c90]: General Plugin Logging Active! (nsPluginHostImpl::ctor)
1[65c90]: NPP Logging Active!
1[65c90]: nsPluginHostImpl::ctor
1[65c90]: nsPluginHostImpl::ScanPluginsDirectory
dir=/d/2/local/pack/mozilla/1.4b/plugins
1[65c90]: Loaded library /d/2/local/pack/mozilla/1.4b/plugins/libnullplugin.so
(load lib)
1[65c90]: NPN callbacks initialized
1[65c90]: ns4xPlugin::GetMIMEDescription called: this=2450f8, result=*:.*:All types
1[65c90]: ns4xPlugin::GetValue called: this=2450f8, variable=1
1[65c90]: ns4xPlugin::GetValue called: this=2450f8, variable=2
1[65c90]: nsPluginTag::RegisterWithCategoryManager
plugin=/d/2/local/pack/mozilla/1.4b/plugins/libnullplugin.so, removing = no
1[65c90]: nsPluginHostImpl::GetPluginFactory End mime=application/x-java-vm,
rv=-2147467259, plugin=0 name=(not found)
1[65c90]: Creating nsHttpHandler [this=b8040].
1[65c90]: nsHttpHandler::Init
1[65c90]: nsHttpHandler::PrefsChanged [pref=(null)]
1[65c90]: nsHttpAuthCache::Init
1[65c90]: Creating nsHttpConnectionMgr @2136e8
1[65c90]: nsHttpConnectionMgr::Init
1[65c90]: nsHttpHandler::StartPruneDeadConnectionsTimer
1[65c90]: nsHttpHandler::Observe [topic="xpcom-shutdown")]
1[65c90]: nsHttpHandler::StopPruneDeadConnectionsTimer
1[65c90]: nsHttpAuthCache::ClearAll
1[65c90]: nsHttpConnectionMgr::Shutdown
1[65c90]: nsSocketTransportService::PostEvent [handler=2136e8 type=0 u=0 v=0]
4[d9aa8]: nsHttpConnectionMgr::OnMsgShutdown
4[d9aa8]:   calling PR_Poll [active=0 idle=0]
1[65c90]: nsSocketTransportService::Shutdown
4[d9aa8]: shutting down socket transport thread...
1[65c90]: Deleting nsHttpHandler [this=b8040]
1[65c90]: nsHttpConnectionMgr::Shutdown
1[65c90]: Destroying nsHttpConnectionMgr @2136e8
1[65c90]: nsPluginHostImpl::dtor
1[65c90]: nsPluginHostImpl::Destroy Called
1[65c90]: nsPluginTag::RegisterWithCategoryManager
plugin=/d/2/local/pack/mozilla/1.4b/plugins/libnullplugin.so, removing = yes
1[65c90]: Unloaded library /usr/local/pack/mozilla/1.4b/libxpcom.so


Reproducible: Always

Steps to Reproduce:

Actual Results:  
Mozilla should start

Expected Results:  
Mozilla exits

Above tests were reproduced on an account that had no existing profile
(no $HOME/.mozilla directory)
(Reporter)

Comment 1

15 years ago
PS: this is a default, vanilla Mozilla/1.4b install,
nothing else is added (zero plugins), esp. no JAVA plugin (which I never install)

The reference to application/x-java-vm must be due to Mozilla itself:

1[65c90]: nsPluginHostImpl::GetPluginFactory End mime=application/x-java-vm,
rv=-2147467259, plugin=0 name=(not found)

Updated

15 years ago
OS: SunOS → Solaris

Comment 2

15 years ago
Does mozilla still fail if you do a % mv ~/.mozilla ~/.mozilla_disabled # to
ensure it starts with no profile ?

Comment 3

15 years ago
2nd question:
Does
http://ftp.mozilla.org/pub/mozilla/releases/mozilla1.4b/mozilla-sparc-sun-solaris2.7-1.4b.tar.gz
work for you (with/without having a preexisting ~/.mozilla) ?
(Reporter)

Comment 4

15 years ago
Re: comment 2 above,

check last two lines of my bug submission :-)
quoting:

Above tests were reproduced on an account that had no existing profile
(no $HOME/.mozilla directory)

Re: comment 3 above,
If the solaris build posted on ftp.mozilla.org has been built with
Sun WorkShop/Forte, remember that GCC users such as myself who built
supporting C libraries such as glibc/gtk+/etc. cannot run it
since you explained me earlier that
  GCC-compiled binaries could use GCC-built or Sun WorkShop-built shared libs
  but Sun WorkShop-built binaries could ONLY use Sun WorkShop-built shared libs

Cheers -- Nicolas
(Reporter)

Comment 5

15 years ago
Nevermind!

I tried the build you point at above and it does work! Well done!
How is that miracle possible?
(Reporter)

Comment 6

15 years ago
Unfortunately the tar file you point at above has Unix permissions all screwed up:
all files are missing the other "R"ead and e"X"ecute bits,
so when you untar this file (as non-root user for security)
since the default is to restore permissions, you end up with a mozilla install
that is all screwed up and unusable by all non-root users on the system
until you go and fix permissions manually :-/

Comment 7

15 years ago
Nicolas Pioch wrote:
> Unfortunately the tar file you point at above has Unix permissions all screwed 
> up:
> all files are missing the other "R"ead and e"X"ecute bits,
> so when you untar this file (as non-root user for security)
> since the default is to restore permissions, you end up with a mozilla install
> that is all screwed up and unusable by all non-root users on the system
> until you go and fix permissions manually :-/

Erm, is it possible that you have a umask like 077 ? :)
"tar" (and nearly all other unix/linux tools) masks the permissions of files it
creates while unpacking using the "umask" mask ...

You can fix the problem after unpacking with a simple % chmod -R og=u,og-w
mozilla # :)
(Reporter)

Comment 8

15 years ago
Nope, my umask is 022,
and the solaris-sparc distribution posted on ftp.mozilla.org is indeed
incorrectly packaged. Proof:
% gtar -ztvf mozilla-sparc-sun-solaris2.7-1.4b.tar.gz | more
drwxr-x--- mozilla/mozilla   0 2003-05-09 10:59 mozilla/
-rwxr-x--- mozilla/mozilla 4916 2003-05-09 10:59 mozilla/DocStream
-rwxr-x--- mozilla/mozilla 4916 2003-05-09 10:59 mozilla/HelloWorld
-rw-r----- mozilla/mozilla 3078 2000-03-21 15:26 mozilla/INSTALL.xmlterm
-rw-r----- mozilla/mozilla 30869 1999-10-06 04:14 mozilla/LICENSE
-rw-r----- mozilla/mozilla  9545 2003-02-24 22:15 mozilla/README.txt
-rwxr-x--- mozilla/mozilla 28628 2003-05-09 10:59 mozilla/TestGtkEmbed
-rwxr-x--- mozilla/mozilla 24196 2003-05-09 10:59 mozilla/TestIPC
-rw-r----- mozilla/mozilla   208 2002-08-02 00:59 mozilla/bloaturls.txt
drwxr-x--- mozilla/mozilla     0 2003-05-09 03:50 mozilla/chrome/
drwxr-x--- mozilla/mozilla     0 2003-05-08 18:07 mozilla/chrome/en-US/
drwxr-x--- mozilla/mozilla     0 2003-05-08 18:07 mozilla/chrome/en-US/locale/

etc.

Extract from the tar manual page "man tar", at option -p:

     p     Restore the named files to their original  modes,  and
           ACLs  if  applicable,  ignoring  the present umask(1).
           This is the default behavior if invoked as  super-user
           with  the  x function letter specified. If super-user,
           SETUID and sticky information are also extracted,  and
           files are restored with their original owners and per-
           missions, rather than owned by root. 

i.e. if you extract as root, broken permissions from inside this incorrectly
packaged tar file will be restored.

Comment 9

15 years ago
OK, tarball permission problem fixed (via hacking the build script... ;-/ ) ...
(Reporter)

Comment 10

15 years ago
Mozilla 1.4rc3 when built with gcc 3.3 doesn't start either.

I'm giving up building Mozilla distributions on Solaris 8
(Reporter)

Comment 11

15 years ago
Here's an updated NSPR_LOG_MODULES=all:5 log with Mozilla 1.4rc3 built with GCC
3.3, after moving away the libnullplugin.so file as suggested by Jim Dunn to
prevent bug 204804

running on an empty profile directory

Files/directories which got created:
  components/compreg.dat
  components/xpti.dat
  $HOME/.mozilla
  $HOME/.mozilla/appreg
  $HOME/.mozilla/default

but then Mozilla exits and never creates
  chrome/chrome.rdf
  chrome/overlayinfo/


% ./mozilla
1[705d0]: Loaded library a.out (init)
1[705d0]: a.out incr => 2 (for getipnodebyname)
1[705d0]: a.out decr => 1
1[705d0]: Loaded library /tmp/moz/libxpcom.so (load lib)
1[705d0]: /tmp/moz/libxpcom.so incr => 2 (find lib)
1[705d0]: /tmp/moz/libxpcom.so decr => 1
1[705d0]: Loaded library /tmp/moz/components/libxpcom_compat_c.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxpconnect.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libuconv.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libucvmath.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libi18n.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libjar50.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/liboji.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libjsd.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libipcdc.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnecko.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnecko2.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libpref.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libcaps.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libchrome.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/librdf.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libhtmlpars.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libgfxps.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libgfxxprint.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libgfx_gtk.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libimgmng.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libimglib2.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libgkplugin.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libjsdom.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libwidget_gtk.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxremote_client.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libgklayout.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmork.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libdocshell.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libprofile.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnsprefm.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libembedcomponents.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libwebbrwsr.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libeditor.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libtxmgr.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libcomposer.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libaccessibility.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmozldap.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnsappshell.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libfileview.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmozfind.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxremoteservice.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libappcomps.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxpinstall.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libcookie.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libwallet.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libwalletviewers.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxmlextras.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libp3p.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libautoconfig.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libtransformiix.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libinspector.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libuniversalchardet.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libtypeaheadfind.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libwebsrvcs.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libxmlterm.so (load lib)
1[705d0]: mozXMLTermShell::RegisterProc: registered mozXMLTermShell
1[705d0]: Loaded library /tmp/moz/components/libaccessproxy.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnkdatetime.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libnkfinger.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libpipboot.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libpipnss.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libpippki.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmailnews.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgdb.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgnews.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/liblocalmail.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmimeemitter.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libvcard.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmime.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgcompose.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgimap.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libaddrbook.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libimport.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libimpText.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libimpComm4xMail.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgmdn.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmailview.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libbayesflt.so (load lib)
1[705d0]: Loaded library /tmp/moz/components/libmsgsmime.so (load lib)
4[c9960]: nsSocketTransportService::Run
4[c9960]:   calling PR_Poll [active=0 idle=0]
1[705d0]: NPN Logging Active!
1[705d0]: General Plugin Logging Active! (nsPluginHostImpl::ctor)
1[705d0]: NPP Logging Active!
1[705d0]: nsPluginHostImpl::ctor
1[705d0]: nsPluginHostImpl::ScanPluginsDirectory dir=/tmp/moz/plugins
1[705d0]: nsPluginHostImpl::GetPluginFactory End mime=application/x-java-vm,
rv=-2147467259, plugin=0 name=(not found)
1[705d0]: Creating nsHttpHandler [this=baaa0].
1[705d0]: nsHttpHandler::Init
1[705d0]: nsHttpHandler::PrefsChanged [pref=(null)]
1[705d0]: nsHttpAuthCache::Init
1[705d0]: Creating nsHttpConnectionMgr @209f50
1[705d0]: nsHttpConnectionMgr::Init
1[705d0]: nsHttpHandler::StartPruneDeadConnectionsTimer
1[705d0]: nsHttpHandler::Observe [topic="xpcom-shutdown")]
1[705d0]: nsHttpHandler::StopPruneDeadConnectionsTimer
1[705d0]: nsHttpAuthCache::ClearAll
1[705d0]: nsHttpConnectionMgr::Shutdown
1[705d0]: nsSocketTransportService::PostEvent [handler=209f50 type=0 u=0 v=0]
4[c9960]: nsHttpConnectionMgr::OnMsgShutdown
4[c9960]:   calling PR_Poll [active=0 idle=0]
1[705d0]: nsSocketTransportService::Shutdown
4[c9960]: shutting down socket transport thread...
1[705d0]: Deleting nsHttpHandler [this=baaa0]
1[705d0]: nsHttpConnectionMgr::Shutdown
1[705d0]: Destroying nsHttpConnectionMgr @209f50
1[705d0]: nsPluginHostImpl::dtor
1[705d0]: nsPluginHostImpl::Destroy Called
Summary: Mozilla 1.4b does not start on Solaris8 → Mozilla 1.4b or 1.4rc3 built with GCC 3.3 does not start on Solaris8

Comment 12

14 years ago
Newer version are out. Still a problem?

pi

Comment 13

14 years ago
I tried with 1.5 the other day without any luck... Unfortunately, don't have any
time to investigate it now - busy tracking down a few other things.

Comment 14

14 years ago
http://bugzilla.mozilla.org/buglist.cgi?query_format=&short_desc_type=allwordssubstr&short_desc=start&long_desc_type=substring&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&bug_status=UNCONFIRMED&bug_status=NEW&bug_status=ASSIGNED&bug_status=REOPENED&rep_platform=Sun&op_sys=Solaris&emailassigned_to1=1&emailtype1=exact&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=exact&email2=&bugidtype=include&bug_id=&votes=&changedin=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&remaction=run&namedcmd=added&order=Reuse+same+sort+as+last+time&field0-0-0=noop&type0-0-0=noop&value0-0-0=
might have an earlier bug describing this problem?

pi

Comment 15

14 years ago
Ok, now I've built 1.6a successfully both with gcc3.3.2@solaris8 and
gcc3.3@solaris9. Optimized with "-02 -mv8". No problem at all. 

In both test, I built glib, gtk+ and libIDL with the same compiler just to be
certain. I even got rid of a crash when using the composer that only surfaced if
built with gcc2.95...

I don't know any good way to speed-test, otherwise a comparison with the
Forte7-build would have been fun. :)

At least in my case, this could now be closed as WFM.

Comment 16

14 years ago
Closing by last comment.

pi
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.