cookies aren't removed from document.cookie when they expire

RESOLVED WORKSFORME

Status

()

Core
Networking: Cookies
RESOLVED WORKSFORME
15 years ago
4 years ago

People

(Reporter: Steven Grimm, Assigned: Darin Fisher)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3) Gecko/20030312

1.4a doesn't remove cookies from document.cookie when you set their expiration
times to the past.  This is a problem when using third-party web components that
create and (try to) delete temporary cookies -- it doesn't take long before you
hit the 20-cookie limit and cookies you care about start to drop off the end of
the list.


Reproducible: Always

Steps to Reproduce:
Visit the URL using 1.3 (or any other JavaScript-capable web browser) and note
which cookies are displayed.

Actual Results:  
In 1.3 (and every other web browser I've tried that supports JS and cookies) the
test page shows the "foobar" cookie on the second line, but not the third. In
1.4a, the "foobar" cookie doesn't go away, even when the page is reloaded.

Expected Results:  
1.4a should behave consistently with earlier versions.
(Reporter)

Comment 1

15 years ago
User agent listed above is the 1.3 browser that works correctly; the 1.4a browser is

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2) Gecko/20030401
(Assignee)

Comment 2

15 years ago
reporter: please upgrade to mozilla 1.4 beta.  i believe this bug has been fixed.
Whiteboard: DUPEME
(Reporter)

Comment 3

15 years ago
Confirmed; it's fixed in 1.4 beta.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 4

15 years ago
no patch, correct resolution is either duplicate or worksforme.
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---
(Assignee)

Comment 5

15 years ago
marking WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → WORKSFORME

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.