.jpg is being appended to filenames on download (even for non-JPEG files)

RESOLVED WORKSFORME

Status

SeaMonkey
Download & File Handling
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Dave HOGUE, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3.1) Gecko/20030425

The RealPlayer plug-in URL is just an example - .jpg is added to EXEs and other
files types (e.g., WMV, MPG, even JPG among them) on download.  This particular
example was frustrating because Mozilla deleted by temp file copy when the file
failed to execute, so I couldn't even rename the cached copy.  I had to use IE
to download the plug-in for Mozilla!  The same problem has occurred when an
image is linked to a file - clicking on the image to download the file often
results in having .jpg appended to the filename (e.g., blah.PDF.JPG or
blah.JPG.JPG or blah.TXT.JPG)

Reproducible: Always

Steps to Reproduce:
1. just try to download the RealPlayer plug-in - it's an autodownload.
2.
3.

Actual Results:  
the 8 meg file downloads, .jpg is appended to the existing .exe filename, the
file fails to execute, Mozilla deletes the cached copy.  Because it's an auto
download, I can't right click and "Save Target As"

Expected Results:  
Mozilla should not append incorrect extensions to filenames

Sometimes there are also problems with downloading files that have redirected
addresses - Mozilla reports that it cannot save the file because it's location
may have changed.

Comment 1

15 years ago
Reporter, please look at your Preferences
Look at Helper Applications located under Navigator

Edit application/octet-string in the list to se if the
.jpg is there under extension

Comment 2

15 years ago
Happens on Win98 SE as well (Mozilla 1.3).  In fact, it happens on the Mozilla
home page when I try to download Mozilla 1.3.1/Win (11 Mb).  It does not happen
on every site, but it does often.  Referring to comment #1,
application/octet-stream is set and defined as type JPEG.  If that is incorrect,
exactly what should it be??

Comment 3

15 years ago
Comment #2:
The extension field should be empty

Comment 4

15 years ago
WORKSFORME Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5a) Gecko/20030711
-
Reporter, if you see this problem in a recent build of Mozilla, feel free
to return and reopen the bug.

RESOLVING WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.