All users were logged out of Bugzilla on October 13th, 2018

checksetup.pl: Use of uninitialized value in crypt at globals.pl line 891.

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
16 years ago
6 years ago

People

(Reporter: mkgnu, Assigned: zach)

Tracking

2.16.3
x86
Linux

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606
Build Identifier: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020606

I am running RH7.2 trying to upgrade a bugzilla 2.10 installation to 2.16.3. I
am using:

# rpm -qa |grep -i mysql
mysql-3.23.56-1.73
mysql-server-3.23.56-1.73
mysql-devel-3.23.56-1.73

# rpm -qa |grep -i perl
openssl-perl-0.9.6b-8
perl-HTML-Parser-3.25-2
perl-NDBM_File-1.75-26.72.3
perl-DateManip-5.39-5
perl-XML-Dumper-0.4-5
perl-HTML-Tagset-3.03-3
perl-DB_File-1.75-26.72.3
perl-Parse-Yapp-1.04-3
perl-5.6.1-26.72.3
perl-SGMLSpm-1.03ii-4
perl-libnet-1.0703-6
perl-URI-1.12-5
perl-libxml-enno-1.02-5
perl-XML-Encoding-1.01-2
perl-XML-Parser-2.30-7
perl-XML-Twig-2.02-2
perl-libwww-perl-5.53-3
perl-CGI-2.752-26.72.3
perl-Digest-MD5-2.13-1
perl-XML-Grove-0.46alpha-3
perl-MIME-Base64-2.12-6
perl-libxml-perl-0.07-5
groff-perl-1.17.2-7.0.2
perl-Storable-0.6.11-6
perl-CPAN-1.59_54-26.72.3
gimp-perl-1.2.1-7

I have setup a 2.10 instance that is a duplicate of the production 2.10 bugzilla
I'm using. I have uncompressed the 2.16.3 bugzilla and run checksetup.pl with
the following error message showing up at some point:

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Use of uninitialized value in crypt at globals.pl line 891, <STDIN> line 5 (#1)
    (W uninitialized) An undefined value was used as if it were already
    defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
    To suppress this warning assign a defined value to your variables.
    
    To help you figure out what was undefined, perl tells you what operation
    you used the undefined value in.  Note, however, that perl optimizes your
    program and the operation displayed in the warning may not necessarily
    appear literally in your program.  For example, "that $foo" is
    usually optimized into "that " . $foo, and the warning will refer to
    the concatenation (.) operator, even though there is no . in your
    program.
    
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++


This last line was repeated a bunch of times.


Reproducible: Always

Steps to Reproduce:
1. Create a duplicate 2.10 bugzilla instance (preferably with meaningful data in
it) by doing:

     $ mysql  mysql;

     mysql> create database bugs;
     Query OK, 1 row affected (0.00 sec)
     mysql> quit

     $ mysql -f -u bugs -psecret bugs < bugs.sql

     $ cd ~/bugzilla-2.10
     # modify in localconfig $webservergroup and $dbpass;
     $ ./checksetup.pl

2. $ lynx http://ftp.mozilla.org/pub/webtools/bugzilla-2.16.3.tar.gz
3. $ tar -zxvf bugzilla-2.16.3.tar.gz 
4. $ cd bugzilla-2.16.3
5. # modify in localconfig $webservergroup and $dbpass;
6. /checksetup.pl

Actual Results:  
# ./checksetup.pl 

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.55
Checking for       CGI::Carp (any)     ok: found v1.25
Checking for    Data::Dumper (any)     ok: found v2.102
Checking for     Date::Parse (any)     ok: found v2.24
Checking for             DBI (v1.13)   ok: found v1.35
Checking for      DBD::mysql (v1.2209) ok: found v2.1026
Checking for      File::Spec (v0.82)   ok: found v0.82
Checking for      File::Temp (any)     ok: found v0.12
Checking for        Template (v2.07)   ok: found v2.07
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929
Checking for       CGI::Carp (any)     ok: found v1.25

The following Perl modules are optional:
Checking for              GD (v1.19)   ok: found v1.19
Checking for     Chart::Base (v0.99)   ok: found v0.99
Checking for     XML::Parser (any)     ok: found v2.30

Checking user setup ...
Precompiling templates ...
Checking for    MySQL Server (v3.22.5) ok: found v3.23.56

Reminder: Bugzilla now requires version 8.7 or later of sendmail.
[root@ebola bugzilla-2.16.3]# 
[root@ebola bugzilla-2.16.3]# ./checksetup.pl 

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.55
Checking for       CGI::Carp (any)     ok: found v1.25
Checking for    Data::Dumper (any)     ok: found v2.102
Checking for     Date::Parse (any)     ok: found v2.24
Checking for             DBI (v1.13)   ok: found v1.35
Checking for      DBD::mysql (v1.2209) ok: found v2.1026
Checking for      File::Spec (v0.82)   ok: found v0.82
Checking for      File::Temp (any)     ok: found v0.12
Checking for        Template (v2.07)   ok: found v2.07
Checking for      Text::Wrap (v2001.0131) ok: found v2001.0929
Checking for       CGI::Carp (any)     ok: found v1.25

The following Perl modules are optional:
Checking for              GD (v1.19)   ok: found v1.19
Checking for     Chart::Base (v0.99)   ok: found v0.99
Checking for     XML::Parser (any)     ok: found v2.30

Checking user setup ...
Precompiling templates ...
Checking for    MySQL Server (v3.22.5) ok: found v3.23.56

Creating table tokens ...
Creating table attachstatusdefs ...
Creating table attachstatuses ...
Creating table duplicates ...
Updating field bug_severity in table bugs ...
Updating field op_sys in table bugs ...
Updating field rep_platform in table bugs ...

Looks like we don't have an administrator set up yet.  Either this is your
first time using Bugzilla, or your administrator's privs might have accidently
gotten deleted at some point.
Enter the e-mail address of the administrator: kristis.makris@datasoft.com
You entered 'kristis.makris@datasoft.com'.  Is this correct? [Y/n] y
Enter the real name of the administrator: Kristis Makris
Enter a password for the administrator account: 
Please retype the password to verify: 
'kristis.makris@datasoft.com' is now set up as the administrator account.
Updating field resolution in table bugs ...
Updating field type initialowner in table components ...
old: tinytext not null
new: mediumint
Updating field type initialqacontact in table components ...
old: tinytext not null
new: mediumint
Populating duplicates table...
Adding new field emailflags to table profiles ...
Adding new field isactive to table groups ...
Adding new field isobsolete to table attachments ...
Deleting unused field emailnotification from table profiles ...
Deleting unused field newemailtech from table profiles ...
Your current installation of Bugzilla stores passwords in plaintext 
in the database and uses mysql's encrypt function instead of Perl's 
crypt function to crypt passwords.  Passwords are now going to be 
re-crypted with the Perl function, and plaintext passwords will be 
deleted from the database.  This could take a while if your  
installation has many users. 
Use of uninitialized value in crypt at globals.pl line 891, <STDIN> line 5 (#1)
    (W uninitialized) An undefined value was used as if it were already
    defined.  It was interpreted as a "" or a 0, but maybe it was a mistake.
    To suppress this warning assign a defined value to your variables.
    
    To help you figure out what was undefined, perl tells you what operation
    you used the undefined value in.  Note, however, that perl optimizes your
    program and the operation displayed in the warning may not necessarily
    appear literally in your program.  For example, "that $foo" is
    usually optimized into "that " . $foo, and the warning will refer to
    the concatenation (.) operator, even though there is no . in your
    program.
    
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:50 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
[Fri May  9 15:43:51 2003] checksetup.pl: Use of uninitialized value in crypt at
globals.pl line 891, <STDIN> line 5.
Fixing password #1... 27... Done.
Deleting unused field password from table profiles ...
Updating field type cryptpassword in table profiles ...
old: varchar(64)
new: varchar(34)
Adding index for who column in longdescs table...
Adding new field removed to table bugs_activity ...
Adding new field added to table bugs_activity ...
Fixing activity log
1...501...1001...1501...2001...2501...3001...3501...4001...4501...5001...5501...6001...6501...7001...7501...8001...8501...9001...9501...10001...10501...11001...11501...12001...12501...13001...13501...14001...14501...15001...15501...16001...16501...17001...17501...18001...18501....
Done.
Deleting unused field oldvalue from table bugs_activity ...
Deleting unused field newvalue from table bugs_activity ...
Adding new field reporter_accessible to table bugs ...
Adding new field cclist_accessible to table bugs ...
Adding new field attach_id to table bugs_activity ...
Removing invalid login cookies...
Deleting unused field cryptpassword from table logincookies ...
Deleting unused field hostname from table logincookies ...
Adding new field ipaddr to table logincookies ...
Reminder: Bugzilla now requires version 8.7 or later of sendmail.

Expected Results:  
Output that contains anything other than errors!

1 - I am not sure I understand what this error message actually means:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Looks like we don't have an administrator set up yet.  Either this is your
first time using Bugzilla, or your administrator's privs might have accidently
gotten deleted at some point.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++



2 - When I ran the 2.10 checksetup.pl when originally setting up the duplicate
instance I got this:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
# cd ../bugzilla-2.10/
[root@ebola bugzilla-2.10]# ./checksetup.pl 
Checking perl modules ...
Checking user setup ...
_ListTables is deprecated, use $dbh->tables() at
/usr/lib/perl5/site_perl/5.6.1/i386-linux/DBD/mysql.pm line 272.
Updating field bug_severity in table bugs ...
Updating field op_sys in table bugs ...
Updating field rep_platform in table bugs ...
Reminder: Bugzilla now requires version 3.22.5 or later of MySQL.
Reminder: Bugzilla now requires version 8.7 or later of sendmail.
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Look above for versions of perl packages used.


3 - I don't know what the severity of this bug should be, since I don't
understand what is actually broken. the 2.16.3 upgraded version *seems* to work
after superficial use.


4 - Note that I could not get the Template tookit to install cleanly. I got this
failed test on it:
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
t/autoform.......FAILED test 21                                              
	Failed 1/25 tests, 96.00% okay
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This is a summary of the failed tests on it.

Failed Test  Stat Wstat Total Fail  Failed  List of Failed
-------------------------------------------------------------------------------
t/autoform.t               25    1   4.00%  21
6 tests skipped.
Failed 1/85 test scripts, 98.82% okay. 1/2430 subtests failed, 99.96% okay.


5 - I will be happy to provide additional information

Comment 1

15 years ago
Have there been any problems with your installation after upgrading? 
Specifically, I wonder about passwords - the warnings would seem to indicate 
that checksetup, when changing how passwords were stored (from plaintext to 
crypted, search for closed bugs on the matter), didn't find the old passwords 
and so was crypting undefined/blank passwords. Note that in your log you had 27 
accounts and 27 lines of error :).

2.10 is long enough ago that I don't know where to acquire a copy to try to 
reproduce this; if you're not having troubles, I suppose it should be marked 
closed.
Version: unspecified → 2.16.3
(Reporter)

Comment 2

15 years ago
I got an email from Jerry at some point saying that somebody fixed this for
3.0.0beta1. I tried using it with 3.0.0 stable and it was working just fine. You
can close this bug.
(Reporter)

Comment 3

15 years ago
Oh wait, I mixed up my bugs, I thought this was Samba 3.

The installation seemed to work though. You can close this bug.

Comment 4

15 years ago
Per reporter.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.