Mail msg link does not open Camino

RESOLVED FIXED

Status

Camino Graveyard
General
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Rick Closson, Assigned: saari (gone))

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030412 Chimera/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030412 Chimera/0.7+

Camino 0.7 is default browser but closed. Apple Mail 1.2.5 (v552) is open to
message with link. Clicking message link does not open Camino. Test: Clicking
email message link when Netscape 7 or IE are set as default browser will open
browser. If Camino is already open, clicking email message link will send Camino
to correct (linked) URL.

Reproducible: Always

Steps to Reproduce:
1.Make Camino default browser
2.Close Camino
3.Open Apple Mail
4.Select email message with embedded URL
5.Click embedded URL. Camino does not open automatically.

Actual Results:  
Camino does not open automatically

Expected Results:  
Camino to open, go to link from email message

Mac OSX 10.2.6 (also occurred on 10.2.5); new iMac 1GHz G4 17"

Extremely SORRY if this is actually a dup. Seems somebody must have notice this
but I followed the steps to check for dups and found none I could identify. BTW,
trying to DL most recent Camino nightly compilations was unsuccessful
("interrupted") for 5 specific dates over the last week. I tried.

Comment 1

15 years ago
Rick, please retest using a current nightly Camino build.
(Reporter)

Comment 2

15 years ago
I have downloaded and installed (actually copied the Camino app to the
Applications folder) Build ID: 2003051004 with no change in results. With Camino
not open, clicking on a message link (as the
http://bugzilla.mozilla.org/show_bug.cgi?id=205157) does not open/startup
Camino. When viewing the message, the cursor arrow rolls over the link to show
the hand icon but clicking does nothing. Right-clicking to "Open Link" also
produces no result. When Camino is open/hidden, clicking the message link opens
a new Camino tab, as expected. As mentioned in my original bug report, this is
with the Apple Mail program.

Comment 3

15 years ago
Sort of WorksForMe using Camino/2003-05-01-05. I have Camino 0.7 in
/Applications and a nightly in ~/Applications. Although the nightly is set as
the default browser, Mail opens 0.7 for some reason.

Comment 4

15 years ago
I think this is a MacOSX problem not a Camino problem.

Rick, can you set Camino as the default browser then trash the browser and click
a URL in Mail? Should open IE or Safari since Mail can't find Camino. After
doing that check the Internet's Web tab to see if Camino was removed from the
list. Redownload the nightly (or whatever release if you like) decompress, copy,
etc, etc... Custom select Camino from the list (or choose Camino if it's already
there) and try again.

Internet's pref are wacky
(Reporter)

Comment 5

15 years ago
This "bug" has fixed itself. After messing around as advised for a few days (I'm
not sophisticated so this was nothing serious), I resigned myself to firing up
Camino manually when I wanted to go to an emailed link. (Clicking the link with
an opened Camino, sent it to the URL.) Then one fine day, it just started
working. Probablly Greg's mental Fu did it. Thanks for all the advice and support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.