If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

remove "www" from History entries like you already do with "http"

VERIFIED FIXED in Firebird0.7

Status

()

Firefox
Bookmarks & History
--
enhancement
VERIFIED FIXED
15 years ago
9 years ago

People

(Reporter: Pham, Assigned: Blake Ross)

Tracking

unspecified
Firebird0.7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

29.37 KB, image/jpeg
Details
619 bytes, patch
Joe Hewitt (gone)
: review+
Details | Diff | Splinter Review
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030504 Mozilla Firebird/0.6

"www" puts History folders in the wrong order

For example, If I have some sites that have "www" and some without it, they
aren't placed in ABC order because the www makes History assume that they should
be a "w" not an "a"

This would make it consistent on how History ignores "htpp://" and let me see
sites in abc order without the "www" corrupting it

IE does
google (www.google.com) so that google is placed in the middle because of the G
and Firebird does
www.google.com which places it near the bottom because of the WWW

It would also be consistent with History>View>By Site which then places google
in the middle, not the bottom

Reproducible: Always

Steps to Reproduce:
1. Go to abc.com, mozilla.org, netscape.com, news.com, cnn.com. google.com
2.
3.

Actual Results:  
They are placed as
1. abc.abcnews.go.com
2. mozilla.org
3. netscape.com
4. news.com.com
5. www.cnn.com
6. www.google.com
in History

Expected Results:  
Place it as
1. abc.abcnews.go.com
2. cnn.com
3. google.com
4. mozilla.org
5. netscape.com
6. news.com.com
or
1. abc.abcnews.go
2. cnn
3. google
4. mozilla
5. netscape
6. news.com
or
1. abc.abcnews.go (abc.abcnews.go.com)
2. cnn (www.cnn.com
3. google (www.google.com
4. mozilla (mozilla.org
5. netscape (netscape.com
6. news.com (news.com.com)
(Reporter)

Comment 1

15 years ago
Created attachment 122925 [details]
IE's is better
(Reporter)

Comment 2

15 years ago
This isn't http://bugzilla.mozilla.org/show_bug.cgi?id=87336 because that one says
to put mozillazine.org and www.mozillazine.org in the same folder

This is about removing "www" from the beginning so that View>ByDateandSite will
put google in the middle and not the bottom
Confirming, I like this concept since it works towards greater ease of use.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Updated

14 years ago
Summary: Copy IE's History>View By Date by removing"www" and placing it in parentheses → remove "www" from History entries like you already do with "http"
(Assignee)

Comment 4

14 years ago
Created attachment 127096 [details] [diff] [review]
patch

Comment 5

14 years ago
Comment on attachment 127096 [details] [diff] [review]
patch

r=hewitt
Attachment #127096 - Flags: review+
(Assignee)

Comment 6

14 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Updated

14 years ago
Target Milestone: --- → Phoenix0.7

Comment 7

14 years ago
v.
http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&subdir=mozilla/toolkit/components/history/src&command=DIFF_FRAMESET&file=nsGlobalHistory.cpp&rev1=1.16&rev2=1.17&root=/cvsroot
Status: RESOLVED → VERIFIED
(Assignee)

Comment 8

14 years ago
I should point out that entries already in your history won't be affected, only
new ones will.
(Reporter)

Comment 9

14 years ago
isn't there a message that says delete your profile everytime you get a new 
download

Updated

9 years ago
Component: History → Bookmarks & History
QA Contact: asa → bookmarks
You need to log in before you can comment on or make changes to this bug.