Auto deleting junk mail removes training from junk mail controls

RESOLVED DUPLICATE of bug 198830

Status

--
major
RESOLVED DUPLICATE of bug 198830
16 years ago
8 years ago

People

(Reporter: farcusnz, Assigned: sspitzer)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

When JMC automatically deletes previously marked junk mail the training from
those mails seems to be lost as same or similar spam is no longer recognised.

Reproducible: Always

Steps to Reproduce:
1.Train junk mail over time.
2.set junk mail to be deleted after several days
3.junk training seems to be lost after emails are deleted automatically as jmc
now fails to recognise same or similar spam.
4.checking training.dat file confirms that data is being lost as the file
increases and decreases in size with mails being deleted both manually and
automatically by jmc

Comment 1

15 years ago
Almost the same as bug 198830
(Reporter)

Comment 2

15 years ago
I seem to have found the cause of this bug.
I have JMC set to send junk mail from all four of my pop accounts to just one
junk mail folder located in my most used account.
Creating a separate junk mail folder for each account seems to have solved my
problem.
Interesting - but it is still something that shouldn't happen when sending to
just one folder.
Also interesting that I seem to be the only one seeing this bug.

Comment 3

15 years ago
I think I'm experiencing this as well.  I have two pop accounts with the
spam from both being sent to a single folder in the first account.

Comment 4

15 years ago
This is probably the same (code-wise) as bug 198830, and therefore should be a
dupe!?
Whiteboard: dupeme

Comment 5

14 years ago

*** This bug has been marked as a duplicate of 198830 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved Duplicate!
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.