can't passed mail server authentication if mail server enabled NT password authentication.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: lee.chintay, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

My mail server is Merak 5.8.5 (http://www.icewarp.com/) on Windows 2000 server.
if enabled mail server "NT password" (used Win2k account) feature then POP3
authentication will failed. but this process is okay in mozilla 1.4a and before.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
maybe related to the CRAM-MD5 checkins...

Comment 2

16 years ago
Reporter, please try again with a nightly build >= 20030509. There was a minor
bug left in the official 1.4b that caused failures in some cases.

If this doesn't help, would you please create a POP3 log file using these
instructions:
http://www.mozilla.org/quality/mailnews/mail-troubleshoot.html#imap

As I currently don't have access to a win2k machine this is the faster way to try.
(Reporter)

Comment 3

16 years ago
1. I'm try nightly build (ID:2003051108) --> failed.
2. I'm use instructions to create POP log and retry POP authentication process
but always failed and POP log file have not any content.

Comment 4

16 years ago
But a log file has been created though it's empty, yes?

In the meantime I got access to an W2K computer and installed Merak 5.8.6. But
it's only W2K Professional and no Domain Controller available. So it looks to me
the "NT password" checkbox in the Special tab doesn't take effect.

If I assign a password in the User tab manually, accessing POP and SMTP with
Mozilla works without problems. Does this also work in you setup?

(Reporter)

Comment 5

16 years ago
But a log file has been created though it's empty, yes?
---> yes. the log file has been created but it's empty.

In the meantime I got access to an W2K computer and installed Merak 5.8.6. But
it's only W2K Professional and no Domain Controller available. So it looks to me
the "NT password" checkbox in the Special tab doesn't take effect.
---> I'm Merak mail server installed in W2K SERVER, so "NT password" checkbox
can useable.

If I assign a password in the User tab manually, accessing POP and SMTP with
Mozilla works without problems. Does this also work in you setup?
---> Yes! you got point.
     I'm use Mozilla 1.4a and before, Merak's "NT password" always set to
enabled and work fine, but Mozilla 1.4b has problems for POP3 authentication
with "NT password", so now I just manual to set mail account password.
(Reporter)

Comment 6

16 years ago
Created attachment 123027 [details]
server monitor
(Reporter)

Comment 7

16 years ago
Created attachment 123028 [details]
active sessions
(Reporter)

Comment 8

16 years ago
If you installed Merak on W2K SERVER and enabled "NT password", then can use
"Server Monitor" and choice "Active Sessions".
You can monitor POP3 authentication session then maybe can more understand
problems .
(Reporter)

Comment 9

16 years ago
Created attachment 123113 [details]
POP3 log

Before I use "NSPR_LOG_MODULES=IMAP:5" to log POP3 session, but log file is
empty.
Now I reuse "NSPR_LOG_MODULES=POP3:5" to log POP3 session, the result is in
attachment.
(Reporter)

Comment 10

16 years ago
I have download Mozilla nightly build 2003051512. It's work fine!
I do'nt know what's changed since nightly build 2003051108, but it's work fine.
This bug have not be found.
Thanks!

Comment 11

16 years ago
We've only done a workaround that disables the new CRAM-MD5 authentication
mechanism by default. You can it switch on again by setting a boolean pref
useSecAuth for the POP server you want. And in 1.5 this will get an UI and maybe
enabled by default again.

As I wrote, that's a workaround for faulty servers, no fix for an bug in Mozilla!

Comment 12

15 years ago
so wfm?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.