mozilla do not show all characters in textarea if included script and nocript

RESOLVED DUPLICATE of bug 109781

Status

()

Core
HTML: Parser
RESOLVED DUPLICATE of bug 109781
15 years ago
15 years ago

People

(Reporter: Miroslav Suchý, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030430 Debian/1.3-5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030430 Debian/1.3-5

I have following minimal piece of HTML code:
<HTML>
<body>
<form>
<textarea cols="80" rows="10" name="sufix">
<script>
</script>
<noscript>
</noscript>
<table width="100%">
<tr><td align="center">
a&nbsp;b&gt;/td>
</tr>
</table>
</html></textarea>
</form>
</Body>
</html>

Mozilla will rander it bad. It do not display attributes in table, td in
textarea. The string &nbsp; is chanded to space too. And when I submit this form
this parts of code are lost.

Text in textarea as mozzila render it:<script>
</script>
<noscript>
</noscript>
<table>
<tr><td>
a b>/td>
</tr>
</table>
</html>

when the character < is replaced by &lt; everything is ok. but very often it is
written as I wrote.


Reproducible: Always

Steps to Reproduce:

Comment 1

15 years ago

*** This bug has been marked as a duplicate of 109781 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.