Dragging icon to toolbar when customize window is open crashes Firebird

VERIFIED DUPLICATE of bug 204781

Status

()

--
blocker
VERIFIED DUPLICATE of bug 204781
16 years ago
12 years ago

People

(Reporter: ehume, Assigned: bugzilla)

Tracking

({crash})

unspecified
Firebird0.6
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6

Starting with the "unofficial" 2003-05-08 build, when user opens Customize
window and drags an icon to a toolbar, Firebird crashes. 

Reproducible: Always

Steps to Reproduce:
1. Open Customize window
2. Drag an icon from the window to a toolbar
3. 

Actual Results:  
Firebird crashes

Expected Results:  
Icon should have inserted itself into the toolbar.

No error messages before the crash.
(Reporter)

Comment 1

16 years ago
Official 2003-05-11 build now available. Using this build I tried pulling an
icon off the toolbar. This crashed FB, but this time invoked Talkback, which
hung. Had to use task manager to kill it. When I restarted FB, Talkback also
restarted--still hung, still requiring the Task manager to kill it.
(Reporter)

Comment 2

16 years ago
Official 2003-05-11 build again. Trying to insert icon into toolbar also invokes
Talkback ater the crash. Talkback also hangs.

Comment 3

16 years ago
Confirming w/ Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030511 Mozilla Firebird/0.6

-> critical
-> Toolbars
Severity: normal → critical
Status: UNCONFIRMED → NEW
Component: General → Toolbars
Ever confirmed: true

Updated

16 years ago
Keywords: crash

Comment 4

16 years ago
Also Confirming w/ Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030511 Mozilla Firebird/0.6

Setting OS -> ALL, since this is not WinXP-only. Can somebody please test this 
on Linux or MacOS X!

IMO this is a serious blocker for 0.6, since one of the major features of 
Firebird and also one of the main advantages over Navigator is totally broken. 
I'm therefore nominating this for 0.6, please change this if you disagree.
Severity: critical → blocker
OS: Windows XP → All
Target Milestone: --- → Phoenix0.6

Comment 5

16 years ago
Works for me w/ Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030511
Mozilla Firebird/0.6
So, this is Win32 specific bug, I think.

Comment 6

16 years ago
I have just tried the following firebird nightly.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030511 
Mozilla Firebird/0.6
I can verify that the problem is still very much with us.  Here are a few 
details.  When one right clicks on the toolbar, selects 'Customize' and 
proceeds to drag icons onto the toolbar firebird crashes.  An error message 
appears which has only the option to close firebird.  Then a talkback window 
appears but it has no buttons and also crashes.  Then once firebird has quit 
and talkback has been manually killed via Task Manager if you reopen firebird 
the crashed talkback window reappears and remains on top and no matter how 
many times firebird and talkback are killed with every new instance of 
firebird the talkback window reappears in crashed form.

Comment 7

16 years ago
Dhruba,

The reason the talkback app (named "spiral_window_name") is starting each time
you start Firebird is the .nub file in
\phoenix\components\Netscape\MozillaFirebird\.

Just delete this file and kill the talkback app one last time. You won't see it
until your next crash.

Comment 8

16 years ago
Works for me on Linux too. (Debian unstable)

Using:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6

Comment 9

16 years ago
Works for me on Red Hat 8 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b)
Gecko/20030512 Mozilla Firebird/0.6)

Comment 10

16 years ago
Talkback does not actually crash, it just has no buttons to click on.
A simple TAB followed by an ENTER will close talkback, and prevent it from 
coming back up after relaunching Firebird.
Stack (from TBID 20027766)
nsEventStateManager::GenerateMouseEnterExit
[d:/nightlybuild/phoenix/trunk/mozilla/content/events/src/nsEventStateManager.cpp,
line 2645]
nsEventStateManager::PreHandleEvent
[d:/nightlybuild/phoenix/trunk/mozilla/content/events/src/nsEventStateManager.cpp,
line 399]
PresShell::HandleEventInternal
[d:/nightlybuild/phoenix/trunk/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6379]
PresShell::HandleEvent
[d:/nightlybuild/phoenix/trunk/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6328]
nsViewManager::HandleEvent
[d:/nightlybuild/phoenix/trunk/mozilla/view/src/nsViewManager.cpp, line 2292]
nsView::HandleEvent [d:/nightlybuild/phoenix/trunk/mozilla/view/src/nsView.cpp,
line 308]
nsViewManager::DispatchEvent
[d:/nightlybuild/phoenix/trunk/mozilla/view/src/nsViewManager.cpp, line 2028]
HandleEvent [d:/nightlybuild/phoenix/trunk/mozilla/view/src/nsView.cpp, line 82]
nsWindow::DispatchEvent
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 1058]
nsWindow::DispatchWindowEvent
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 1075]
nsWindow::DispatchMouseEvent
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 5198]
ChildWindow::DispatchMouseEvent
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 5453]
nsWindow::ProcessMessage
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 3976]
nsWindow::WindowProc
[d:/nightlybuild/phoenix/trunk/mozilla/widget/src/windows/nsWindow.cpp, line 1349]
USER32.dll + 0x2a244 (0x77e3a244)
USER32.dll + 0x45e5 (0x77e145e5)
USER32.dll + 0xa792 (0x77e1a792)
nsAppShellService::Run
[d:/nightlybuild/phoenix/trunk/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 479]
main1 [d:/nightlybuild/phoenix/trunk/mozilla/toolkit/xre/nsAppRunner.cpp, line 1297]
xre_main [d:/nightlybuild/phoenix/trunk/mozilla/toolkit/xre/nsAppRunner.cpp,
line 1698]
main [d:/nightlybuild/phoenix/trunk/mozilla/browser/app/nsBrowserApp.cpp, line 52]
WinMain [d:/nightlybuild/phoenix/trunk/mozilla/browser/app/nsBrowserApp.cpp,
line 65]
WinMainCRTStartup()
KERNEL32.dll + 0x2847c (0x77ea847c) 
Same stack as bug 204781

*** This bug has been marked as a duplicate of 204781 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 13

16 years ago
I believe marking Bug 205273 as a duplicate of bug 204781 may be premature. I am
working with the 2003-05-12 build of MozillaFirebird compiled by Pryan. I can't
seem to replicate whatever bug 204781 is supposed to do, but bug 205273
continues to plague Firebird.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030512 Mozilla
Firebird/0.6
Fair enough, let's revisit this after 204781 is fixed.
Status: RESOLVED → REOPENED
Depends on: 204781
Resolution: DUPLICATE → ---

Comment 15

16 years ago
WFM now that bug 204781 is fixed.
Using yesterday's second Win32 nightly (2003-05-13-21-trunk).
I can also confirm, that the checkin for bug 204781 has fixed this using
Mozilla/5.0 (Windows NT 5.0; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6. 

Marking as DUPLICATE again.

*** This bug has been marked as a duplicate of 204781 ***
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → DUPLICATE

Comment 17

16 years ago
v.
Status: RESOLVED → VERIFIED
Taking QA Contact
QA Contact: asa → bugzilla

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.