Add Galeonesque search toolbar functionality

VERIFIED WONTFIX

Status

()

Firefox
Toolbars and Customization
--
enhancement
VERIFIED WONTFIX
15 years ago
11 years ago

People

(Reporter: Greg, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Hmm.  While the toolbar to the side is an interesting idea, I find it much
better the way Galeon does it.  There is a "URL" and "SMART URL" field in the
bookmark editor; the URL is activated by pressing the favicon, while the SMART
URL is similar in functionality to the keyword search.  Basically, entering,
say, "http://everything2.org/index.pl?node=%s" automatically creates a resizable
entry field (with a favicon or text button) in a special "Smart Bookmarks
Toolbar".  It is possible to have any number of search engines in it--it acts
just like the Bookmarks Toolbar, but with entry fields that send input to %s.  I
think this is a good replacement for both the small, dynamically selectable
search item on the normal toolbar, and the keyword search, and the numerous
extensions that provide this.  It's handy for, say, Debian users to have a smart
bookmark of "http://packages.debian.org/cgi-bin/search_packages.pl?keywords=%s",
as opposed to relying on the limited functionality provided by extensions.

I would imagine it wouldn't take too much work.

Reproducible: Always

Steps to Reproduce:
1.Launch Galeon, look at smart bookmark toolbar.
2.Launch Phoenix, look at its absence.
3.Compare.

Actual Results:  
I saw that Phoenix did not have this.

Expected Results:  
Implemented a simple smart bookmark toolbar.
So let's get this straight: you want to scrap Firebird's established search
interfaces in favour of the Galeon smart toolbar concept?  Despite your
statement that various extensions and existing core elements already provide
this functionality?

Since this is basically asking the devs to scrap their established design
concepts for a completely different interface that can be added via an
extension, I'm going to just mark this one WONTFIX.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX

Comment 2

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Comment 3

15 years ago
VERIFYING obvious WONTFIX bugs.  Filter on firebirdWontFix to filter these bugs.
 I skipped a few that I'm unsure about from their summary and will manually go
through them.
Status: RESOLVED → VERIFIED
*** Bug 216764 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
*** Bug 218279 has been marked as a duplicate of this bug. ***

Comment 6

15 years ago
Which core elements provide the functionality of these search boxes?

Updated

11 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.