Java 2 re 1.3 plugin not installing properly

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
15 years ago
13 years ago

People

(Reporter: Terrell Larson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

This web site triggers the java plugin install from netscape.  There are 2 problems:

1) it does not indicate that one must be root to do this.  
2) as root - it says the linux install under debian woody is successful.  In
fact it is lying.  libstdc++-libc6.1-1.so.2 is needed.

Reproducible: Always

Steps to Reproduce:
1.fresh install of the mozilla 1.4b.  Visit www.angelena.info
2.
3.

Actual Results:  
if you run mozilla from a CLI - it will print the message that the
libc6.1-1.so.2 is not found

Expected Results:  
Should find something that works.

I did a symlink:  

/usr/lib# ln -s /usr/lib/libstdc++-libc6.2-2.so.3 libstdc++-libc6.1-1.so.2

This seems to fix the problem (perhaps)

If you go to the graphics section in the website - some of the java works and
some does not.  This may be related to installation or it may be related to
other issues.  I have not checked the java code.  I am not a java programmer at
this time.

Comment 1

14 years ago
Confirming with Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040514.

But it looks like more a tech evang bug.
Product: Browser → Seamonkey

Comment 2

13 years ago
Netscape no longer provides a java xpi (for linux, at least) and I can't find
anywhere else that does either.

resolving WORSKFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.