Closed Bug 205291 Opened 19 years ago Closed 19 years ago

Release notes: glibc 2.2 required

Categories

(SeaMonkey :: Build Config, defect)

x86
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.4final

People

(Reporter: martin, Assigned: leaf)

Details

I just downloaded 1.3.1 and 1.4b for linux (the tar.gz files) which both require
glibc 2.2 now.
I'm running a bastardized RedHat 6.2 system, glibc 2.1.3, and noticed this
requirement too.  Will the newer releases require 2.2?
Moving to more appropriate product, assignee.
Component: Miscellaneous → Build Config
Product: mozilla.org → Browser
Target Milestone: --- → mozilla1.4final
Version: other → Trunk
Depends on which fix is chosen for the libstdc++ issue, in part.  The short
answer, however, is that Red Hat 6 is unlikely to be supported and glibc 2.2 (at
least) will probably be required.
Assignee: mitchell → granrose
What changed to make it required now?
At least, the 1.4b Release Notes should be updated. That would have saved me a
13MB download over a 56K modem :(

http://mozilla.org/releases/mozilla1.4b/#require
This change needs to made as soon as possible. The versions are out and the
release notes blatantly wrong.
I am also stuck with glibc 2.1.3, and a 56k modem. I read the release notes
specifically for this kind of information.
The System Requirements section of the release notes for 1.4rc1 and 1.4b reflect
the change, but the very next section, Compatibility Information, still states
Mozilla only requires glibc 2.1.

The release notes for 1.3.1 are still wrong in both sections.
could we make this a blocker for 1.4?
It's a simple fix, it needs to be done, and I don't think it should wait 3 more
months.
my bad it seems like the release notes for 1.4b were updated.
http://mozilla.org/releases/mozilla1.4b/#require

Should this bug be closed or is there a change to apply on the trunk?
If anyone is interested:
I can provide nightly and release builds for older Linux systems (e.g.
pre-glibc-2.2).
If there is demand in that please file a NEW bug and assign it to
roland.mainz@informatik.med.uni-giessen.de
Currently running 1.4RC1. Tried to install 1.4RC2. I get following error.

./mozilla-installer-bin: /lib/libc.so.6: version `GLIBC_2.2.4' not found
(required by ./mozilla-installer-bin)

Installed is glibc-2.2.2 (Suse 7.2). The README still states the minimum
requirements are glibc 2.1

Also tried the nightly build of june 24th. Same problem.

Is it just the installer that's build against glibc-2.2.4 or does Mozilla
require glibc-2.2.4 now? I urgently need to move from RC1 as it's just too
unstable - I'd prefer to move to RC2, but otherwise I'll have to downgrade.
glibc 2.2.4 dependency is clearly listed in the rc2 release notes:
http://mozilla.org/releases/mozilla1.4rc2/

leaf fixed this so reassigning before resolving.
Assignee: granrose → leaf
fixed.
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.