Click on link in mail opens browser even though browser not needed

NEW
Unassigned

Status

MailNews Core
Attachments
--
minor
15 years ago
10 years ago

People

(Reporter: John Edmondson, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

I receive emails with a link to a TIF file on the server.  I have a helper
application designated in my preferences to allow me to view the file.  Under
previous versions of Mozilla, when I clicked on the link to the tif file in the
email, the helper application would open and allow me to view the link.  Under
Mozilla 1.4b, the browser is opened and focus is taken away from mail and then
the helper application is opened.

Reproducible: Always

Steps to Reproduce:
1. See above
2.
3.

Actual Results:  
When I select the link and the helper application is opened, the browser is
opened if not already open and focus to shifted to the browser and away from mail.

Expected Results:  
I expect the helper application to open without opening the browswer or shifting
focus to the browser if it is already open.  This is an anoyance when reading
through multiple emails with links.

Because I use Mozilla mail to access fax images that we receive on a fax server,
I find it very annoying; however, I realize that is not a major issue.
Confirmed; this is a result of the change to how you kick off the URL load, Seth....
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

15 years ago
This occurs in RC1, Build 2003052908, as well
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → attachments
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.