Radio buttons on form do not show selection

RESOLVED DUPLICATE of bug 113453

Status

()

Core
HTML: Form Submission
--
minor
RESOLVED DUPLICATE of bug 113453
15 years ago
15 years ago

People

(Reporter: Andrew Irish, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030401

At the given URL, there is a poll (validates as XHTML at the W3Cs validator). 
Clicking the radio buttons does not appear to alter their state, until you click
down on the submit button.  The same problem appears in phoenix (Mozilla/5.0
(X11; U; Linux i686; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5) and K-Meleon
(Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.2b) Gecko/20021016 K-Meleon 0.7)

A test page using the same HTML and CSS, but only the form (i.e. none of the
text), does not reproduce the problem.

Also, using the same page (clicking options) in opera at the same time alters
the values selected in Mozilla.

Reproducible: Always

Steps to Reproduce:
1.Go to http://www.bleurgh.net/fhall/
2.Click items in the poll ("Who is your favourite staff member?" at the time of
writing)
3.See that the options don't change until you press the submit button (can click
and hold then move cursor off of submit button)
4.Open the same page in Opera, and click options, then switch back to mozilla

Actual Results:  
None of the poll options become the selected value until the submit button is
pushed.  Changing values in opera changes values in mozilla.

Expected Results:  
Shown which radio button was selected.  Not been affected by Opera.
(Reporter)

Comment 1

15 years ago
OK, addendum.

It appears I am a fool.  Opera does *not* alter the values; the bug is a redraw
problem.  Switching away from mozilla and then back to it redraws the form,
showing the selected value (as does clicking the submit button).

So, it's just a redrawing thing.  But I've only seen it on that one page, and it
doesn't seem to be due to bad web design.

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 113453 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.