Folder Pane (Mail account window) keeps scrolling to bottom

RESOLVED WORKSFORME

Status

--
minor
RESOLVED WORKSFORME
16 years ago
13 years ago

People

(Reporter: jamesrome, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
This has happened twice for me now. I am on build 2003050714. I am not sure what
triggers this. I was sending mail with attachments, and suddenly the top left
pane in my mail window (with the account and mailboxes) started scrolling
towards the bottom. I have an IMAP and several POP accounts.

Once this happens, it keeps scrolling downwards, even if you try to move the
pane upwards with the slider bar.

The only solution is to restart Mozilla.

Comment 1

16 years ago
I have seen similar behavior in the thread pane (upper-right), using 1.4b-0516 
on Windows 2000.  I did not have to restart, but I did have to fiddle with the 
mouse and grabbing at the scrollbar's thumb before it stopped.  The scrolling I 
saw was rather slow.

Comment 2

15 years ago
*** Bug 221700 has been marked as a duplicate of this bug. ***

Comment 3

15 years ago
Copying report from duped bug 221700:

=============

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4)
Gecko/20030624

The mail/news accounts/folders window continuously scrolls down to the bottom. 
I can navigate to different folders with the keyboard arrow keys.  I can use the
scroll bar to scroll up in the window, but after a second the window starts
scrolling down.  Actively trying to continue scrolling the window up causes the
window to shudder up and down.  The scrolling does not effect which folder is
selected.

[snip]

No other mozilla windows or elements were effected, nothing else on the PC was
effected.
The problem started when I deleted the last message in one folder.  every thing
I tried without closing the mail client did not effect the problem.
After closing and reopening the mail client I have not been able to reproduce
the problem.

[snip]

Comment 4

15 years ago
I've seen this problem too, a few times in a few years.  IIRC, it happened after
dragging and dropping a message from the message list to the folder pane.

bug 208759 looks like the same thing, but in a different pane (the message list)

Comment 5

15 years ago
severity -> minor
Severity: normal → minor

Comment 6

15 years ago
Coincidentally, I just had the problem:

Confirm on Moz 1.5 final / WinXP Pro

Some notes:

* If I drag up the scrollbar and hold it, it jumps up and down for half a
second, then scrolls back down, even though I'm still holding down the mouse button.

* If I use the up arrow key, once I get past the top of the pane (where it
should start scrolling up), it jumps to the selected folder, then scrolls back down.

* Opening and closing the folder pane with the grippy made no difference

* I tried just closing MailNews, leaving the browser only, and -- CRASH.  All of
Moz crashed ... but no Quality Feedback Agent!  Doh!  I don't see talkback.exe
anywhere.  Was it left out of the zip file for 1.5?

Here's what Windows XP Event Log | Applications had to say:

==================
Event Type:	Error
Event Source:	Application Error
Event Category:	None
Event ID:	1000
Date:		11/6/2003
Time:		1:05:27 PM
User:		N/A
Computer:	xxx

Description:
Faulting application mozilla.exe, version 1.5.20031.716, faulting module
unknown, version 0.0.0.0, fault address 0x04a88fc9.

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 6d 6f 7a   ure  moz
0018: 69 6c 6c 61 2e 65 78 65   illa.exe
0020: 20 31 2e 35 2e 32 30 30    1.5.200
0028: 33 31 2e 37 31 36 20 69   31.716 i
0030: 6e 20 75 6e 6b 6e 6f 77   n unknow
0038: 6e 20 30 2e 30 2e 30 2e   n 0.0.0.
0040: 30 20 61 74 20 6f 66 66   0 at off
0048: 73 65 74 20 30 34 61 38   set 04a8
0050: 38 66 63 39 0d 0a         8fc9..  

========================

Comment 7

15 years ago
I was able to reproduce this error in Moz 1.7b on Win 2K. I received an HTML
format email with three images in it. I opened the email in its own window. I
dragged one of the photos down onto a 'photos' folder in windows explorer that
was visible on the taskbar. I waited until the 'photos' folder popped up and
then I dropped the image into my folder. Then I returned to the Mozilla mail
window to find my mail messages list (inbox) scrolling uncontrollably. I closed
the mozilla window but the mozilla process was still visible in the task
manager, even though I don't use QuickLaunch. I killed this task then repeated,
and the same thing happened.

Comment 8

15 years ago
Uncontrolled scrolling of the Thread pane is bug 190503.  Similar to the symptom 
noted in comment 7, if the program is exited while this scrolling is active, it 
never fully unloads from memory.
Summary: Mail account window keeps scrolling to bottom → Folder Pane (Mail account window) keeps scrolling to bottom

Comment 9

15 years ago
*** Bug 247272 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail

Comment 10

14 years ago
I think, i found way to reproduce it. This bug is anonying (i'm mozilla user
from ~2000 and saw this sooo many times).
On WinXP :
Select mail/news message. Move mouse from top to bottom of message list, and in
the way - select other message. In short - select message in mouse move from top
to bottom. 
I can reproduce this bug 2 times from 3 tries ;-) So maybe info HOW to reproduce
it may help to fix this oooooold bug. I can even make short video how to
reproduce it if someone needs it.
Update - the same works on Win2000 - i can reproduce without problems.
As allways, closing mail client helps.
Note that bug 190503 has been WFM'd; there was a low-level change to tree widget 
scrolling in May which appears to have fixed that problem, and I suspect it 
fixes this as well; however, I was never able to reproduce this particular bug.

James Rome, guanxi -- please test with a current build of Seamonkey and state 
whether you can reproduce this problem or not.
(Reporter)

Comment 12

14 years ago
I have not seen this happen lately, so I guess it is WFM too.
=> WFM per reporter's comment 12.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.