All users were logged out of Bugzilla on October 13th, 2018

Plugin installation appears to work, but plugins not found.

RESOLVED DUPLICATE of bug 198562

Status

()

--
major
RESOLVED DUPLICATE of bug 198562
16 years ago
16 years ago

People

(Reporter: ofudd, Assigned: peterlubczynski-bugs)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030508

I've just tested three plugins with Mozilla 1.4b.

1. Java (from http://wp.netscape.com/plugins/jvm.html)
2. RealPlayer 8 (from
http://forms.real.com/real/player/unix/unix.html?src=050803realhome_1_1)
3. MozPlugger (from http://mozplugger.mozdev.org/)

The first two appear to install, but don't show up in Help/About Plugins, and
Java Applets don't run (they claim that I need to install JRE).

The (nonworking) JRE did get installed in /usr/lib/mozilla-1.4b/plugins, right
next to the (working) libnullplugin.so.

The (working) Mozplugger got installed in /usr/lib/mozilla/plugins.

The (nonworking) RealPlayer is at /usr/lib/netscape/plugins/rpnp.so and
/usr/local/netscape/plugins/rpnp.so

Reproducible: Didn't try

Steps to Reproduce:
1. Install Java from http://wp.netscape.com/plugins/jvm.html
2. Try running a java applet from any web page
3. 

Actual Results:  
Applet not loaded, jigsaw-puzzle icon appeared in its place, clicking on it says:
  This page contains information of a type (application/x-java-vm) that can only
be viewed with the appropriate plug-in.

Expected Results:  
Run the plugin.

Tested 2003-5-12 with Mozilla 1.4b, downloaded today.
RedHat 9.0 with updates.
Default theme.
Reporter:
If you use "about:buildconfig" as URL, which GCC do you see there ?
(the answer depends on WHICH mozilla build you use, the rpm or the tar.gz)

If Mozilal is compiled with gcc:
1) Java is invalid/dupe because you must use the latest JRE Beta from SUn
because the old JRE is compiled with GCC2.95 and they are not binary compatibel.
2) is a dupe

FYI: You can see all plugins in the URL "about:plugins" and if you click on the
second URL in this page (plugindoc) you will find help how to find the correct
JRE for Linux
(Reporter)

Comment 2

16 years ago
about:buildconfig says this:
---------------------------------
Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -pedantic -Wno-long-long -pthread -pipe
c++ 	gcc version 3.2 20020903 (Red Hat Linux 8.0 3.2-7) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -pedantic -Wno-long-long
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --libdir=/usr/lib --enable-optimize=-O2 --disable-debug
--with-default-mozilla-five-home=/usr/lib/mozilla-1.4b --enable-strip-libs
--disable-tests --disable-short-wchar --enable-nspr-autoconf
--enable-extensions=default,irc --without-mng --enable-crypto --disable-xprint
--without-system-nspr --with-system-zlib --enable-default-toolkit=gtk2
--disable-freetype2 --enable-xft --mandir=/usr/share/man
(Reporter)

Comment 3

16 years ago
Ok, Blackdown J2SDK works.  Thanks!

Would it be possible to write code that prevents this kind of error?

Maybe on startup, check the plugins, and if there are any that don't work, say
something?

Or during auto-installation of a plugin (see
http://wp.netscape.com/plugins/jvm.html) maybe immediately uninstall it and/or
complain loudly if it doesn't work.

Is there a way to uninstall plugins besides using the command line?

Thanks!
Netscape must fix their plugin page but not possible for a webpage to detect
which plugin the browser needs (a gcc3.2 or GCC2.95 one).

And they will only fix this if they use GCC3.2 for their next release and not
GCC2.95 that they use now (and also the official Mozilla.org builds [the RPMs
are unofficial builds])

marking as dupe of bug 198562 (for the realplayer)

*** This bug has been marked as a duplicate of 198562 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 5

16 years ago
I'm aware that it's not possible for a web page to detect Gcc versions.

It's only possible for the browser to detect this after the installation.

It might be an idea to have the browser say something ("Ptooii!  This is bad
code!") or do something ("I'm throwing out this bad code, it stinks!") as soon
as it detects it.

Why?  Because it can, and because it would look better than it looks now.  Right
now bad plugins seem to install perfectly but then don't show up on the list of
plugins, which is hard to debug.
You need to log in before you can comment on or make changes to this bug.