www.hazis.nl - "window.event has no properties" message in JavaScript console and expansion on menu does not happen

RESOLVED FIXED

Status

Tech Evangelism Graveyard
Dutch
P4
normal
RESOLVED FIXED
15 years ago
3 years ago

People

(Reporter: Carl van Denzen, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4b) Gecko/20030507

The problem occurs in a Getronics intranet home page. An other browser expands
the menu when you click on p.e. BatchView. Mozilla does not.
I have downloaded and installed java 1.4.1_01 from Sun.
The error in the console says:
Error: window.event has no properties
Source file: http://www.hazis.nl/framework_bar.htm Line: 65

A problem is, that www.hazis.nl is not accessible from the internet.

Reproducible: Always

Steps to Reproduce:
1.open the page
2.click on BatchView
3.
Actual Results:  
Error message in javascript console

Expected Results:  
Expand the menu item

Source:
(Reporter)

Comment 1

15 years ago
Created attachment 123049 [details]
the page that caused the error

Comment 2

15 years ago
If I'm not mistaken, the event object is passed as the first parameter to the
event handler.

Comment 3

15 years ago
window.event is a propietary MS extension.

the function should be coded something like this:
function clickHandler(e) {
  if (!e) e=window.event;
...

and other checks to use standard coding instead of MS specific (document.all ->
document.getElementById)

-->Evangelism, this is not a bug in Mozilla.
Assignee: rogerl → nitot
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → Europe: West
Ever confirmed: true
OS: Linux → All
Product: Browser → Tech Evangelism
QA Contact: pschwartau → brantgurganus2001
Hardware: PC → All
Version: Trunk → unspecified
http://www.hazis.nl/framework_bar.htm is 404, reporter please check if the bug
still occurs.
moving this bug to the new dutch component anyway.
Assignee: nitot → dutch
Component: Europe: West → Dutch
QA Contact: brantgurganus2001 → dutch
Summary: "window.event has no properties" message in JavaScript console and expansion on menu does not happen → www.hazis.nl - "window.event has no properties" message in JavaScript console and expansion on menu does not happen

Comment 5

15 years ago
entire site is more or less off-line : even the main page is an under
construction page. Resolving as "fixed" for the moment.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Priority: -- → P4
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.