caret browsing (F7) jumps over tables

RESOLVED DUPLICATE of bug 144000

Status

()

Core
Keyboard: Navigation
RESOLVED DUPLICATE of bug 144000
15 years ago
15 years ago

People

(Reporter: daf, Assigned: Aaron Leventhal)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6

wen using caret browsing (F7) if it encouters a table wile pressing down it will
jump over it to the next line after it.
Note that  pressing up will work correctely will making the cursor enter the
table, a

Reproducible: Always

Steps to Reproduce:
1. Open a web page with a table based layout
2. activate caret browsing (F7)
3. Press down 

Actual Results:  
the cursor will jump over the table, into the next line after it.

Expected Results:  
Moved into the table

I've noticed this becouse i use it to do keybord only browsing and this bug is
realy anoing

Comment 1

15 years ago
-> Browser
-> Keyboard Navigation
Assignee: blaker → aaronl
Component: General → Keyboard: Navigation
Product: Phoenix → Browser
QA Contact: asa → sairuh
Version: unspecified → Trunk
(Assignee)

Comment 2

15 years ago
Does it behave differently if you open this page in Composer (Ctrl+E)? I doubt
taht it does.

Bugs with arrowing generally belong to jfrancis or mjudge.

Comment 3

15 years ago
i was just complaining about this the other day on #composer.

I believe this was caused by the grippies feature that was added to tables.

qa: all annoying features of this feature aren't detailed in comment 0, someone
could build a table of responses if they felt like it.
Assignee: aaronl → jfrancis
Component: Keyboard: Navigation → Editor: Core

Comment 4

15 years ago
I don't understand; this bug is filed against a browser, not an editor.  This is
not an editor:core bug.  Perhaps it is a selection bug?

timeless--what is the "grippies" feature?

-->aaronl
Assignee: jfrancis → aaronl
Component: Editor: Core → Keyboard: Navigation

Comment 5

15 years ago
Must be a recent regression because 1.4b works for me.
(Reporter)

Comment 6

15 years ago
Bug re-checking with: "Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a)
Gecko/20030720 Mozilla Firebird/0.6"
Still there.

Comment 7

15 years ago
Created attachment 142946 [details]
testcase01 table and body tags

Comment 8

15 years ago
Created attachment 142947 [details]
testcase02 body and p tags

Comment 9

15 years ago
Created attachment 142948 [details]
testcase03 body tags only

Comment 10

15 years ago
after trying out my testcases, i realized that this has nothing to do with tables.

*** This bug has been marked as a duplicate of 144000 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.