Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
6 years ago

People

(Reporter: larson, Assigned: myk)

Tracking

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818; Pfizer Computational Chemistry; .NET CLR 1.0.3705)
Build Identifier: 

It would be nice if "file:" urls would be hyperlinked like "http:" urls 
currently are.


Reproducible: Always

Steps to Reproduce:

Comment 1

16 years ago
In Mozilla mail messages, a file name beginning with "file:/some/unix/path"
should be treated as a hyperlink, and when clicked on, Mozilla should open
this file in the browser (if possible).  This is the behavior in the old
Netscape Messenger.  In Mozilla, this string format is highlighted as if it
was a hyperlink, and with the right mouse button, there is an option to
"Open Link in New Window", but neither this, nor clicking will actually
open the file in a Mozilla browser window.

This behavior can be replicated by simply sending yourself an email with
a file URL to a real file in your $HOME directory.  You will not be able
to open this hyperlink in Mozilla mail.

-Harry Berggren (05/22/03)
(Reporter)

Comment 2

16 years ago
I would like the url to be hyperlinked in the show_bug.cgi page.  Note that the 
following http url is hyperlinked, but the file url is not:

http://some.web.server
file:/some/unix/path

Comment 3

16 years ago
Why would you want to do that? On an open Bugzilla, it's impossible to make it
cross-platform, and you'll end up confusing people visiting that bug.

OTOH, if you're in a very controlled environment where everybody mounts the
exact same filesystem, then I can see a (very limited) use for this. So, what's
the rationale?
(Reporter)

Comment 4

16 years ago
Yes, my Bugzilla installation is on an intranet where everyone has access to 
the same filesystems.

It would also be very useful to hyperlink UNC-style paths, e.g.
file://myserver/some/path

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Due to the security implications on a public installation I think this is best
left as a local hack.

This is an incredibly easy modification by the way.

Look in globals.pl for "sub quoteUrls"

In that sub is a line that looks like this:

    my $protocol_re =
qr/(afs|cid|ftp|gopher|http|https|mid|news|nntp|prospero|telnet|wais)/i;

Just follow the pattern and add "file" to that line.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.