download manager reports negative file size and download speed on files larger than 2.?? GB

VERIFIED DUPLICATE of bug 184452

Status

SeaMonkey
Download & File Handling
--
trivial
VERIFIED DUPLICATE of bug 184452
15 years ago
13 years ago

People

(Reporter: Adrian Hill, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2.1) Gecko/20021130

I tried downloading a 2.9 GB file from my local server and I noticed that the
filesize was reported to be -1311140kb.  Once the "transferred" component
reached the overflow point, the download speed changed sign from 12?? kb/s to
-12?? kb/s.  

Reproducible: Always

Steps to Reproduce:
1.Setup a downloadable file over 2 GB on a web server.
2.Try downloading it.
3.

Actual Results:  
Filesize was reported to be negative.  Time remaining field was blank.

Expected Results:  
Mozilla should have reported a positive value for a filesize.
This is a dup of all the necko and progress APIs being 32-bit.
Whiteboard: DUPEME

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
V.
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
Did the download complete?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.