Asking for plan or photo after for any entry fails : window open then close

RESOLVED FIXED in mozilla1.5alpha

Status

()

Core
DOM: Core & HTML
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: Vincent Nicolas, Unassigned)

Tracking

({fixed1.4})

Trunk
mozilla1.5alpha
fixed1.4
Points:
---
Bug Flags:
blocking1.4 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [HAVE FIX], fixed1.4, URL)

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

Clicking on links should open a pop-up with plan or photo. Instead, a blank page
is opened but it is then instantaneously closed.
Used to work until recently (build 20020414, 1.3 and before)


Reproducible: Always

Steps to Reproduce:
1. Go to http://www.pagesjaunes.fr/
2. Ask for example : Infogrames as "nom" and Lyon as "Localité"
3. Clic one link among "Plan / Itinétaire" or "Plan"

Actual Results:  
No window stays open

Expected Results:  
A pop-up window with some content
(Reporter)

Comment 1

15 years ago
Created attachment 123118 [details]
Simple case

The problem seems to be linked to the naming of the window to open.
The code could be found strange but it is a workaround for older browser.
It get it from the pagesjaunes.fr site.

Comment 2

15 years ago
Confirming on Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030512
Step 3 was missing in the description above

Steps to Reproduce:
1. Go to http://www.pagesjaunes.fr/
2. Ask for example : Infogrames as "nom" and Lyon as "Localité"
3. Click on 'Rechercher', a new window opens with 2 results
4. Clic one link among "Plan / Itinétaire" or "Plan"

Comment 3

15 years ago
Confirming also, with Mozilla trunk binary 2003051214 on WinNT.
Vincent: thank you for providing a reduced testcase!

We create a named window via window.open(), close it, and open
a second window. The issue is, can we use the same window name?

In a current Mozilla build we cannot. The second window never
comes up. Reassigning to DOM Level 0 -


/*
 * This is not working. The same window name is used twice -
 */
function WOpen()
{
  w = window.open("", "moz");
  w.close();
  w = window.open("http://www.mozilla.org", "moz");  // <---- never comes up
  w.focus();
}


/*
 * This is working. Two different window names are used -
 */
function WOpen_ok()
{
  w = window.open("", "moz1");
  w.close();
  w = window.open("http://www.mozilla.org", "moz2");
  w.focus();
}
Assignee: rogerl → dom_bugs
Status: UNCONFIRMED → NEW
Component: JavaScript Engine → DOM Level 0
Ever confirmed: true
QA Contact: pschwartau → ashishbhatt
Created attachment 123176 [details] [diff] [review]
Proposed fix, make window.open() not reuse closed windows.

Updated

15 years ago
Status: NEW → ASSIGNED
OS: Windows 2000 → All
Hardware: PC → All
Whiteboard: [HAVE FIX]
Target Milestone: --- → mozilla1.5alpha

Updated

15 years ago
Attachment #123176 - Flags: superreview?(bz-bugspam)
Attachment #123176 - Flags: review?(caillon)
Attachment #123176 - Flags: superreview?(bz-bugspam) → superreview+
Comment on attachment 123176 [details] [diff] [review]
Proposed fix, make window.open() not reuse closed windows.

>+static PRBool
>+IsItemActive(nsIDocShellTreeItem *aItem)

The only comment I'd really have is consider renaming this method to
"ItemIsActive".  It sounds better for the places it is used:
e.g., |if (ItemIsActive())| sounds more natural than |if (IsItemActive())|. 
But it's not a huge deal.

Oh, and don't forget to land the interface change which I don't see in this
patch.

r=caillon
Attachment #123176 - Flags: review?(caillon) → review+
Um, no interface change needed here :-)

And yeah, I'd be happy to rename the method, I'll try to remembed to do that
when I land this change :-)
Right.  I somehow convinced myself that GetClosed() was a new method.  Ignore
that bit.  :-)

Comment 8

15 years ago
The not working URL is that of french Yellow Pages, I assume the not-working of
Mozilla on this URL will be highly visible in France.
Patch with R + SR is available for 2 weeks, could that get checked in?
Flags: blocking1.4?
Fix checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 10

15 years ago
jst, can you land this on the 1.4 branch as well? 
Flags: blocking1.4? → blocking1.4+
Fix checked in on the 1.4 branch.
Whiteboard: [HAVE FIX] → [HAVE FIX], fixed1.4

Updated

15 years ago
Keywords: fixed1.4

Comment 12

15 years ago
The problem appears to be fixed.

Trunk and branch build 2003-06-12: Mac 10.1.5 - ok.
Trunk and branch build 2003-06-12: Win2k - ok.

Following the steps in comment# 2, this problem appears fixed on the trunk/branch:
Steps to Reproduce:
1. Go to http://www.pagesjaunes.fr/
2. Ask for example : Infogrames as "nom" and Lyon as "Localité"
3. Click on 'Rechercher', a new window opens with 2 results
4. Clic one link among "Plan / Itinétaire" or "Plan"

Results: A pop-up window with content appears and remains open. Within the
pop-up window I select the photo link and a picture of a building appears and
again the pop-up window remains open.

Can we mark this bug as verified1.4?
You need to log in before you can comment on or make changes to this bug.