popup menu persists if menubar item clicked

RESOLVED DUPLICATE of bug 204770

Status

SeaMonkey
General
--
minor
RESOLVED DUPLICATE of bug 204770
15 years ago
13 years ago

People

(Reporter: Scott Craig, Unassigned)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

A right click on the page brings up a popup menu. It disappears if the page is
left-clicked (good). But, if an item from the menu item is clicked (such as
"Bookmarks" or "Help"), then the popup menu stays, and becomes unresponsive to
the left click on the page.  It even persists if a new page is loaded (via
bookmark or Go/Back say).  The popup menu remains active -- choosing an item
from the frozen menu works (sort of, but in the context of the new page if
loaded.)  Another right click destroys the popup, and produces another in a new
location, which will behave properly if the page is left-clicked (first).

Reproducible: Always

Steps to Reproduce:
1. Right click on the page to get popup menu.
2. Click "Go" button on menubar.
3. Left-click on the page.

Actual Results:  
The popup does not disappear.

Expected Results:  
The popup should vanish when the menubar is clicked, or at least when the page
is subsequently left-clicked.

Comment 1

15 years ago
Right click menu disappears as soon as I click on a menu item.

Using a one hour old CVS based trunk - linux.

Maybe your bug has been crushed after 1.4b release ?

Comment 2

15 years ago
Supose it´s a dupe of
Bug 204770 Folders in Personal Toolbar Folder and advanced toolbar button
options don't collapse automatically

Comment 3

15 years ago
Agreeing with comment 2. Duping.
Reporter : notice that this bug is fixed in the May 13+ builds.

*** This bug has been marked as a duplicate of 204770 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.