All users were logged out of Bugzilla on October 13th, 2018

Mail stopped appearing in Draft folder after adding a new draft

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: renelanz, Assigned: Bienvenu)

Tracking

({dataloss})

Trunk
x86
Linux
dataloss

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.4b) Gecko/20030508
Build Identifier: 1.4b on Linux (PC), selfcompiled with gcc 2.95.2

I already had a message in my pop3-Draft folder and composed a new one. After
saving multiple times and sending it later on, I found that my first message in
the Draft folder has disappeared. Don't know, if it disappeared after the sent
one has been deleted from Drafts or before. After compacting the folder, the
message reappeared!



Reproducible: Didn't try

Steps to Reproduce:
1. Save new mail (Appears in Drafts) [pop3-Account]
2. Compose a new one (Appears in Drafts)
3. Send message from #2
4. Drafts does not contain any entries anymore. Compact Draft-folder and message
reappears!

Actual Results:  
First mail is sometimes invisible in Draft-folder. Compacting folder solves
problem (makes it visible again)

Expected Results:  
First mail is always visible in Draft-folder
(Reporter)

Updated

16 years ago
Keywords: dataloss
(Assignee)

Comment 1

16 years ago
I tried this and it worked for me.

Do the draft messages have the same subject, or different subjects? Is the draft
folder threaded or sorted? Do you have the draft folder open the whole time? If
you select another folder and come back to the draft folder, does the first
message re-appear?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

16 years ago
The messages had different subjects. Sorting was done for date and I had the
following fields visible: Thread, Subject, Junk, Recipient, Flag, Date, Size. I
can't remember if I had the draft folder open or not, but changing for and back
to Drafts didn't bring me the message back! Even the message count was 0, but
the size >0. Therefore I did a compress and the message reappeared...

One message was text only, the other html. I was not able to reproduce
unfortunately yet. Will continue trying...

Comment 3

16 years ago
For 1.4b, saving from mail compose with Ctrl-s says 'mail saved in Drafts',
but it does not appear there even after Mozilla restart. The contents is
indeed in the Drafts file of the account (I have two accounts), but the msf
file must have some error, though it mentions the mail. Even when deleting 
the .msf and recreating by a new Mozilla start gives a wrong (and different .msf),
and still no mail appears in Drafts (which is usually closed when I work).

So something is definitely broken here and is really critical.
Flags: blocking1.4?

Comment 4

15 years ago
mozilla1.4 shipped. unsetting blocking1.4 request.
Flags: blocking1.4?

Comment 5

15 years ago
works for me too
can you attach the draft folder that produces the wrong .msf file?
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.