M130 freezes on some pages

RESOLVED INVALID

Status

()

Core
Plug-ins
--
critical
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Daniel Mladek, Assigned: Peter Lubczynski)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Using RH8. Mozilla1.3 installed from mozilla-1.3-0_rh8_xft.rpms (downloaded from
your site)

I recently found that very stable Mozilla till now start crashing when I
entersome URL.  It's happening quite often and it is very annoying... and make
me afraid to browse new URLs:-( to prevent lost my work (I'm using lots of WEB
iterface's application like Bugzilla,etc...)

One of URLs is:
http://www.sreality.cz/reality/detail.asp?imid=913420259

You have little hury up to go to this URL, cause it wond be there for ages 
(simply it will disappear soon I guess).

This page is possible to view in Konqueror 


Reproducible: Always

Steps to Reproduce:
1. just enter mentioned URL
2.
3.

Actual Results:  
Mozilla freez and I have kill its proccesses :-(


Expected Results:  
Shoudln't freez of'course;-)

I used rebuilded src.rpm of mozilla-1.3-0_rh8_xft, so I thought it is because
of this. So I install yours packages with force over mine rpm -ivh --force
mozilla*.rpm, cause it couldn't be installed/upgraded/removed becasue of some
dependencies
But problem didn't disappear.

Comment 1

15 years ago
WFM 2003050714/trunk/W2K

Reporter, could you install the latest nightly build (or 1.4b) and try it again?
http://ftp.mozilla.org/pub/mozilla/nightly/latest/
Keywords: hang
Summary: Mozilla 1.3 crashes on some pages → M130 freezes on some pages

Comment 2

15 years ago
WorksForMe using FizzillaMach/2003-05-07-14-1.4b.

Comment 3

15 years ago
Works for me - Linux with mozilla cvs 2003050923
(Reporter)

Comment 4

15 years ago
And Whats' about this page:
http://www.oskarmobil.cz/
My Mozzilla 1.3 freez too:-(

I'll check it with newer Mozilla
(Reporter)

Comment 5

15 years ago
I tried with 1.3.1 and 1.4 Beta release and bouth crashe (exactly freeze) too:-(

But I found it is because of my plugins :-(((
I have somewhere plugins directory containing lots of plugins.
And when I link this directory to currently used mozilla then it happens that on
mentioned URLs mozilla freezes :-\

 
(Reporter)

Comment 6

15 years ago
I'm gonna attache html page (about:plugins) which I have installed and also
conntent of the plugins dir.
(Reporter)

Comment 7

15 years ago
Created attachment 123261 [details]
My installed mozilla plugins

Shows all installed plugins for mozilla 1.3
(Reporter)

Comment 8

15 years ago
I can't attach comprimed archiv of my plugins directory :-(
Se, here is at least a list of its content:
>$ l
celkem 1132
lrwxrwxrwx    1 root     root           28 kvì  8 21:06 java2 ->
/usr/local/java/j2re1.4.1-BD/
-rw-r--r--    1 root     root       946108 lis 20 16:41 libflashplayer.so
lrwxrwxrwx    1 root     root           45 dub 14 17:50 libjavaplugin_oji.so ->
./java2/plugin/i386/mozilla/javaplugin_oji.so
-rwxr-xr-x    1 root     root        24977 bøe 14 16:13 libnullplugin.so*
-rwxrwsr-x    1 delphym  users       28277 srp 28  2002 plugger.so*
-r--r--r--    1 delphym  delphym      4139 kvì 19  2001 raclass.zip
-r-xr-xr-x    1 delphym  delphym    131580 kvì 19  2001 rpnp.so*
-rw-r--r--    1 root     root         2363 lis 20 16:41 ShockwaveFlash.class


I have installed also rpm package of
plugger-4.0-17

Comment 9

15 years ago
-> Plug-ins
Assignee: general → peterlubczynski
Component: Browser-General → Plug-ins
QA Contact: general → bmartin
(Reporter)

Comment 10

15 years ago
also a link java2 point to install place of
j2re-1.4.1-01-linux-i586-gcc3.2.bin
(Assignee)

Comment 11

15 years ago
reporter: can you reproduce with Mozilla built with gcc 2.x?

Try removing plugins one by one to find which one is at fault.
(Reporter)

Comment 12

15 years ago
Peter,
what exactly do you mean by:
>Mozilla built with gcc 2.x?
I'm not sure about which build, version,type of installer/tgz use.

Is it valid only for rpm packeges? then only RPM of 1.3 build by gcc 3.2 for RH8
are available :-/
On the release pages is mentioned:
    RPMS for Red Hat Linux 8.x with Xft support (Compiled with GCC 3.2 - Read
the release notes before filing Java-related bugs!) (does not support Xprint) 
    RPMS for Red Hat Linux 8.x with Gtk2 support (Also compiled with GCC 3.2 -
You've been warned!) (does not support Xprint)

So, tell me please URL of any Mozilla build you wish I try and I'll download it.
But if it will be RPM, I'm afraid can't uninstall current mozilla without
breaking dependency: Evolution 1.2  now need lots of wile...


Any way...I'm gonna check which plugin causes freezing of my mozilla..
but be little bit patient please...

(Assignee)

Comment 13

15 years ago
The nightlies are still built with gcc 2.x me thinks:
http://ftp.mozilla.org/pub/mozilla/nightly/latest/mozilla-i686-pc-linux-gnu.tar.gz
(Reporter)

Comment 14

15 years ago
Thanks...
till now I detect which plugin cause freezing. It is ShockWave.
Ar least after removing those 2 files from plugins dir:
-rw-r--r--    1   946108 lis 20 16:41 libflashplayer.so
-rw-r--r--    1     2363 lis 20 16:41 ShockwaveFlash.class

problem disappear...

I'll check behaviour of mozilla build with gcc 2.x
(Reporter)

Comment 15

15 years ago
And you're right. The night builds are compiled with gcc 2.x
(When I ran night build it complains that it cant load JRE plugin, which is the one form 
BlackDown compilled with gcc 3.2)

But... Mozilla (night build of 1.4b) still freezing when accessing some URLs
(eg. www.oskarmobil.cz) which try to load Macromedia x-shockwave-flash plugin.

But it is interesting 'cause eg. www,seznam.cz uses on its pages Macr. x-shockwave-flash 
plugin too, and it doesn't freez :-|


so problem is definitely in Macromedia x-shockwave-flash plugin (don't know how to 
check version, and some additional info about this plugin, but) I'm gonna check their pages 
and try the newest...

(Reporter)

Comment 16

15 years ago
Uffff....
I check Macromedia flash player pages and realy! They have newer version at I
was using. After upgrading to currently available v.6 problem disappered :-)))

I'm very sorry I insulted you with this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.