Browser exits abruptly when visiting the specified URL

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Lars Fastrup, Unassigned)

Tracking

({crash, stackwanted})

Trunk
x86
Windows 2000
crash, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

The browser exits without further notice when loading the following page: 

http://java.sun.com/features/2003/05/bloch_qa.html

I have observed the problem in Mozilla 1.3.1 and Mozilla 1.4 Beta

Reproducible: Always

Steps to Reproduce:
1. Visit http://java.sun.com/features/2003/05/bloch_qa.html
2.
3.

Actual Results:  
Browser exists abruptly

Expected Results:  
It should display the web page!
(Reporter)

Comment 1

15 years ago
Sorry I forgot som info on my environment:

PC: Compaq Evo D510 SFF
Processor: Intel Pentium 4 - 2,4 GHz
RAM: 768MB
OS: Windows 2000 (5.0.2195 Service Pack 3 Build 2195)

Comment 2

15 years ago
WFM Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030512
Java Plug-in

    File name: NPJava11.dll
    Java Plug-in 1.4.2 for Netscape Navigator (DLL Helper)

The small Java Icon came up, and I could view the site as expected,
but I couldn´t start View->Page Info, View->Page Source, or Ctrl+I, Ctrl+U,
also can´t save Page, but maybe my Windows needs some love.

Comment 3

15 years ago
When I committed, the connection seemed to be frozen, so I deleted the tab with
the java-URL, and in this moment the message was sent, the SaveAs-box came up,
windows for PageInfo and PageSource popped up.

Comment 4

15 years ago
WFM with Mozilla/5.0 (Windows; U; Win98; de-AT; rv:1.4b) Gecko/20030507 and
Java(TM) Plug-in: Version 1.4.0
also page-wource and so on.

but many java-messages from java-console:
java.security.AccessControlException: access denied (java.net.SocketPermission
servlet.java.sun.com resolve)

	at java.security.AccessControlContext.checkPermission(Unknown Source)

	at java.security.AccessController.checkPermission(Unknown Source)

	at java.lang.SecurityManager.checkPermission(Unknown Source)

	at java.lang.SecurityManager.checkConnect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.checkPermission(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)

	at sun.plugin.cache.CachedFileLoader.download(Unknown Source)

	at sun.plugin.cache.CachedFileLoader.load(Unknown Source)

	at sun.plugin.cache.FileCache.get(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connectWithCache(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(Unknown Source)

	at sun.net.www.protocol.http.HttpURLConnection.getResponseCode(Unknown Source)

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

java.security.AccessControlException: access denied (java.net.SocketPermission
servlet.java.sun.com resolve)

	at java.security.AccessControlContext.checkPermission(Unknown Source)

	at java.security.AccessController.checkPermission(Unknown Source)

	at java.lang.SecurityManager.checkPermission(Unknown Source)

	at java.lang.SecurityManager.checkConnect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.checkPermission(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.plugin.net.protocol.http.HttpUtils.followRedirects(Unknown Source)

	at sun.plugin.cache.CachedFileLoader.download(Unknown Source)

	at sun.plugin.cache.CachedFileLoader.load(Unknown Source)

	at sun.plugin.cache.FileCache.get(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connectWithCache(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.connect(Unknown Source)

	at sun.plugin.net.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

	at sun.net.www.protocol.http.HttpURLConnection.getHeaderField(Unknown Source)

	at sun.net.www.protocol.http.HttpURLConnection.getResponseCode(Unknown Source)

	at sun.applet.AppletClassLoader.getBytes(Unknown Source)

	at sun.applet.AppletClassLoader.access$100(Unknown Source)

	at sun.applet.AppletClassLoader$1.run(Unknown Source)

	at java.security.AccessController.doPrivileged(Native Method)

	at sun.applet.AppletClassLoader.findClass(Unknown Source)

	at sun.plugin.security.PluginClassLoader.findClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadClass(Unknown Source)

	at java.lang.ClassLoader.loadClass(Unknown Source)

	at sun.applet.AppletClassLoader.loadCode(Unknown Source)

	at sun.applet.AppletPanel.createApplet(Unknown Source)

	at sun.plugin.AppletViewer.createApplet(Unknown Source)

	at sun.applet.AppletPanel.runLoader(Unknown Source)

	at sun.applet.AppletPanel.run(Unknown Source)

	at java.lang.Thread.run(Unknown Source)

Updated

15 years ago
Severity: normal → critical
Keywords: crash

Comment 5

15 years ago
No crash using FizzillaMach/2003-05-07-14-1.4b, but I do see a general
exception, java.lang.ClassFormatError:jic_tic (Bad magic number).

Lars, does TalkBack run after these crashes? If so, please provide a
representative incident ID.
Keywords: stackwanted
(Reporter)

Comment 6

15 years ago
No, TalkBack does unfortunately not run after the crash!
(Reporter)

Comment 7

15 years ago
Hmm, seems to be a Java problem. When I select the Java Console from Tools ->
Web Development then Mozilla also crashes.

I then tried to disable Java after which the web page in question displayed
without trouble.

Comment 8

15 years ago
can't be confirmed with 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b)

Comment 9

15 years ago
wfm using build 2003070405 (trunk) on Linux + Sun's JRE 1.4.2.
Do you still crash with 1.4 and JRE 1.4.2 ?
(Reporter)

Comment 10

15 years ago
No. I can not reproduce the bug with Mozilla 1.4 and Java 1.4.2 :-)

Comment 11

15 years ago
Marking WFM as per reporter comments.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.