Pause in keystrokes causes dropdown list to discontinue find as you type.

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
16 years ago
16 years ago

People

(Reporter: sdavis, Assigned: aaronlev)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.4b) Gecko/20030507

I have a dropdown list of names from a database.  If I type SONNY without
pausing,  the selected item changes in the list with each keystroke and I end up
on the first person named Sonny.  If I type SON, then pause, then type N, it
jumps back to the first name beginning with an N.  It would be nice if the time
delay were a configurable option in Preferences, so that you could either
increase it or turn it off entirely.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Assignee)

Comment 1

16 years ago
This is the intended behavior, the same as in Microsoft Windows dropdowns.

I realizes it's not the ideal accessible behavior, especially because you cannot
configure the timeout -- but we're mimicing Windows' behavior with our widgets.

If you want to try fixing it to be configurable, then go ahead and make a hidden
pref for it or something. The current timeout is in the code here:

http://lxr.mozilla.org/seamonkey/source/layout/html/forms/src/nsListControlFrame.cpp#106
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.