JVM crash some time after abort first applet [@ typeinfo name for std::bad_exception]

RESOLVED DUPLICATE of bug 190636

Status

Camino Graveyard
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 190636
15 years ago
15 years ago

People

(Reporter: Michael Blakeley, Assigned: Peter Lubczynski)

Tracking

({crash})

Details

(crash signature, URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030513 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.4b) Gecko/20030513 Camino/0.7+

If I load the URL above, but close the window before the applet finished
loading, Camino will crash some time later. The crash log seems to point to the
JVM or the JVM plug-in. Mac OS 10.2.6, iBook (2001 dual-USB) 500MHz/384MB.

Question: how do I tell which Java Plug-in my system is using, so I report that,
and upgrade if needed? about:plugins shows me a blank window.

$ ls -l /Library/Internet\ Plug-Ins/ ~/Library/Internet\
Plug-Ins//Library/Internet Plug-Ins:
total 1032
-rwxrwxr-x   1 root     admin         963 Apr 29 23:27 Java Applet Plugin Enabler
drwxrwxr-x   3 root     admin         102 Jul 27  2002 Java Applet.plugin
drwxrwxr-x   3 root     admin         102 Feb 26 15:26 JavaPluginCocoa.bundle
drwxrwxr-x   3 root     admin         102 Apr 28 16:20 QuickTime Plugin.plugin
-rw-rw-r--   1 root     admin     1022371 Apr 30 22:42 Shockwave Flash NP-PPC
-rw-rw-r--   1 root     admin        2394 Apr 15 17:23 nsIQTScriptablePlugin.xpt

/Users/mblakele/Library/Internet Plug-Ins:
total 0
drwxrwxrwx   4 mblakele staff         136 Mar 24 07:07 PDF Browser Plugin.plugin


Reproducible: Always

Steps to Reproduce:
1. Open Camino
2. Load the URL
3. Close the window before the applet finished loading
4. Browse non-java content for 10-15 minutes

Actual Results:  
Camino quits unexpectedly

Expected Results:  
Camino should not quit

will attach crash log
(Reporter)

Comment 1

15 years ago
Created attachment 123141 [details]
crash log

Contains two crashes, identical to my eyes. The stacktrace is on thread 21,
both times.
(Reporter)

Comment 2

15 years ago
After doing some research, it appears that Camino packages its own MRJPlugin
within the application. As an experiment, I just tried opening Camino's package
and deleting the MRJ Plug-in folder from the package, in the hopes that this
would cause Camino to fall back on Apple's java plug-in, and that Apple's
wouldn't crash. But re-launching Camino and following the "steps to reproduce"
led to the same crash as in my original crash log.

Is it possible to conclude from this that Camino doesn't use its built-in
plug-in?  Well, it's only 16kB, so I guess not much would be gained by
eliminating it.... Is it just a shim to wrap Apple's plug-in? Maybe the bug is
there, but could Camino's plug-in trap it?

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 190636 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Keywords: crash
Resolution: --- → DUPLICATE
Summary: JVM crash some time after abort first applet → JVM crash some time after abort first applet [@ typeinfo name for std::bad_exception]
Crash Signature: [@ typeinfo name for std::bad_exception]
You need to log in before you can comment on or make changes to this bug.