`java_wrapper_obj' might be used uninitialized in jsj_WrapJSObject

VERIFIED FIXED

Status

Core Graveyard
Java: Live Connect
--
trivial
VERIFIED FIXED
15 years ago
7 years ago

People

(Reporter: timeless, Assigned: timeless)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

fix
590 bytes, patch
Patrick C. Beard
: review+
Details | Diff | Splinter Review
(Assignee)

Description

15 years ago
js/src/liveconnect/jsj_JSObject.c:253 (See build log excerpt)
  `java_wrapper_obj' might be used uninitialized in this function
jsj_WrapJSObject(JSContext *cx, JNIEnv *jEnv, JSObject *js_obj)
(Assignee)

Comment 1

15 years ago
Created attachment 123146 [details] [diff] [review]
fix
(Assignee)

Updated

15 years ago
Attachment #123146 - Flags: review?(beard)

Comment 2

15 years ago
*** Bug 205028 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

15 years ago
Attachment #123146 - Flags: superreview?(dmose)

Comment 3

15 years ago
Comment on attachment 123146 [details] [diff] [review]
fix

sr=dmose@mozilla.org

Comment 4

15 years ago
Comment on attachment 123146 [details] [diff] [review]
fix

sr=dmose@mozilla.org
Attachment #123146 - Flags: superreview?(dmose) → superreview+

Comment 5

15 years ago
Comment on attachment 123146 [details] [diff] [review]
fix

r=beard
Attachment #123146 - Flags: review?(beard) → review+
(Assignee)

Comment 6

15 years ago
checked in
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 7

15 years ago
Checkin verified -
Status: RESOLVED → VERIFIED
(Assignee)

Updated

7 years ago
Component: Java: Live Connect → Java: Live Connect
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.