Image resizing doesn't keep aspect ratio

VERIFIED INVALID

Status

VERIFIED INVALID
16 years ago
9 years ago

People

(Reporter: willy, Assigned: jdunn)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4a) Gecko/20030401
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.4a) Gecko/20030401

When opening an image in browser and zooming into it via Mouse gestures plugin,
the vertical zoom factor is wrong. When zooming in, images are vertically zoomed
with factor 4 instead of 2; when zooming out, the vertical zoom factor is 0.25
instead of 0.5. This happens only the first time zooming an image. The image
keeps the wrong aspect ratio until reloading it.


Reproducible: Always

Steps to Reproduce:
1. Install the Mouse gestures plugin http://optimoz.mozdev.org/gestures/
2. Open an image into the browser or right-click and select "View Image" over an
inline image.
3. Draw a diagonal mouse gesture top-left to down-right or vice versa. 

Actual Results:  
The vertical image size was wrong.

Expected Results:  
Resizing the image with equal horizontal and vertical values.

This problem was reproduced with Mozilla 1.4 Beta too.

Comment 1

16 years ago
Reporter, this isn't the place to log bugs in extensions. Please report the bug
at http://optimoz.mozdev.org/gestures/bugs.html

Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
Summary: Image resizing doesn't keep aspect ratio → Image resizing doesn't keep aspect ratio
this is also a duplicate of another bug (which is also invalid)

marking verified (the extension does have a bug and its author knows about it)
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Image: Painting → Image: Painting
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.