Cannot Load Preferences at Begining - prefs.js, line 42: SyntaxError: illegal character

RESOLVED DUPLICATE of bug 191557

Status

()

--
major
RESOLVED DUPLICATE of bug 191557
16 years ago
16 years ago

People

(Reporter: camronearl, Assigned: ccarlen)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.91 KB, application/x-javascript
Details
(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030507

Everytime I start up Mozilla I get this error:  "An error occured reading the
startup configuration file.  Please contact your administrator.  prefs.js, line
42: SyntaxError: illegal character."  Because of this none of my settings which
I saved are remember durring my next session...highly annoying.  How in the
world can I fix this?

Reproducible: Always

Steps to Reproduce:
1. Start up Mozilla
2. As Mozilla is starting up, error happens

Actual Results:  
I am given the error stated above in the section called, "details" and my
settings are not saved.

Expected Results:  
I have no clue

Comment 1

16 years ago
Camron,

* Have you edited your prefs.js file by hand?

* Can you please attach your prefs.js file to this bug so it can be looked at to
see whats causing the error you're seeing? [file is found in your mozilla user
directory.]

... then once you attach that file so we can see it you can rename it to
something else or delete it and things will hopefully clear up.
Assignee: general → ccarlen
Component: Browser-General → Preferences: Backend
QA Contact: general → sairuh
(Reporter)

Comment 2

16 years ago
Created attachment 127508 [details]
My 'prefs.js' file

I was asked to upload this...it is what causes the problem I think
(Reporter)

Comment 3

16 years ago
After this problem made me go insane after the fifty billionth time of trying to
get it to stop, I finally ended up uninstalling the program. Here recently after
finding that there really is no better browswer out there I decided to get it
once again.  Since doing so the problem still exists.  I get this stupid error:
  "prefs.js, line 42: SyntaxError: illegal character" - I have now attached my
pref.js file, and I hope this can be of some help. As well since then I've tried
the latest version of Netscape, and it as well gives me the same error.  So, get
back to me on what the dill-yo is...thank you.
(Assignee)

Comment 4

16 years ago
It's not a user pref file, but a default pref file, or part of one. All the
prefs in this file begin with "pref" not "user_pref" I'm pretty sure this is the
only place we form pref strings which get written out:
http://lxr.mozilla.org/seamonkey/source/modules/libpref/src/prefapi.cpp#600 -
hardcoded to emit "user_pref" I would think that somehow the contents of your
prefs.js file got switched with those of another file. Can you run a hard disk
check/repair program on your drive?

The only thing you can do with that prefs.js is to remove it. A new one will be
generated.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
Also bugs on WINDOWS ME!!

I did this on Version 1... and is still doing it on Version 1.4

Never loads without some error relating to the configuration file and a syntax
error.

I'm new here... maybe someone else will fix it.

;)

*** Bug 219806 has been marked as a duplicate of this bug. ***
Summary: Cannot Load Prefferences at Beggining - prefs.js, line 42: SyntaxError: illegal character → Cannot Load Preferences at Begining - prefs.js, line 42: SyntaxError: illegal character

*** This bug has been marked as a duplicate of 191557 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.