Phoenix (but not Mozilla) ignoring "background-image" url in CSS styles / "Find My Match" button appears in gray, even though CSS is set to display red (and Mozilla correctly displays the button in red)

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
15 years ago
15 years ago

People

(Reporter: Marc Abramowitz, Assigned: Blake Ross)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3a) Gecko/20021207 Phoenix/0.5

Actually this happens with all of the red buttons on the entire site at
http://personals.yahoo.com, but I chose to focus on one concrete example to
simplify the discussion.

Viewing the source, the button is of CSS class "yperbttnlgbrdr".

This CSS style is defined at http://personals.yahoo.com/css/yperadv.css as: 

.yperbttnlgbrdr {
	background-image:
url(http://us.i1.yimg.com/us.yimg.com/i/us/per/gr/btn/lrg.red.100x18.gif);
	color: #ffffff;	
	width: 100px;
	font-weight: 800;
}

Apparently, it is ignoring the red button background image at
http://us.i1.yimg.com/us.yimg.com/i/us/per/gr/btn/lrg.red.100x18.gif

This button appears red in both IE and Mozilla. It's only gray in Phoenix
(Firebird?), which really puzzles me, since I thought Phoenix and Mozilla were
using the same HTML rendering engine.

So is Phoenix ignoring the background-image even though Mozilla is not?

Reproducible: Always

Steps to Reproduce:
1. Go to http://personals.yahoo.com in Phoenix 0.5 and Mozilla
2. Observe the color of the "Find My Match" button
3.

Actual Results:  
In Phoenix, the button has a gray, rectangular background.
In Mozilla, the button has a red, rectangular but slightly rounded background.

Expected Results:  
Phoenix should be rendering the background-image exactly the way Mozilla does.

This is the CSS style that is not rendering properly:

.yperbttnlgbrdr {
	background-image:
url(http://us.i1.yimg.com/us.yimg.com/i/us/per/gr/btn/lrg.red.100x18.gif);
	color: #ffffff;	
	width: 100px;
	font-weight: 800;
}

Comment 1

15 years ago
Works for me. I see the red background for the button.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030513 Mozilla
Firebird/0.6

Seb?

Comment 2

15 years ago
WFM using Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030429 Mozilla Firebird/0.6

0.5 is way too old anyway, you should upgrade before reporting bugs (as advised
here: http://texturizer.net/firebird/bugs.html )
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.