Closed Bug 205690 Opened 21 years ago Closed 21 years ago

Edit menu of History window contains 2 empty items`

Categories

(Core Graveyard :: History: Global, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: Martijn.Ras, Assigned: bugzilla)

References

Details

Heya Folks,

In between the menu entry "Delete" and the separator before the menu entry
"Select All" there are 2 empty menu entries, that appear to be useless.

Looking at "content/communicator/history/history.xul" in comm.jar it appears as
if someone's forgotten to either remove the accesskeys or add the labels for the
commands "deleteHostnameCmd" & "deleteDomainCmd".

Mazzel,

Martijn.
Confirmed in build 2003051408 on Mac OS X 10.2.6
Had another look into this, the items aren't exactly useless. Problem is that
they're not filled correctly. When the history opens the items are empty, when
you click on one of the days the items are filled but greyed out. Once you
select a URL the items are activated ...

1) Click Go
2) Click History
3) Click Edit, notice Today being selected.
4) Move the mouse pointer over the menu, notice the 2 empty items between Delete
and Select All.
5) Select a node (day or hostname), notice the items now contain "Delete Host"
and "Delete Domain".
6) Select a leaf (page), notice the items now contain "Delete all from" and
"Delete entire domain".

I see three different scenarios here:

1) A day is selected, the items ought to be greyed out.
2) A node is selected, the items ought to read "Delete all from <hostname>" and
"Delete entire domain <domainname>"
3) A leaf is selected, the items ought to read "Delete all from <hostname>" and
"Delete entire domain <domainname>"

This seems to be related with bug <a
href="http://bugzilla.mozilla.org/show_bug.cgi?id=148959">#148959</a> and the
discussion under bug <a
http://bugzilla.mozilla.org/show_bug.cgi?id=81065">#81065</a>.
*** Bug 210637 has been marked as a duplicate of this bug. ***
This was fixed during the last few days by the checkin for bug 227053.
Resolving as fixed.
Status: NEW → RESOLVED
Closed: 21 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.