If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Phoenix product should be changed to Mozilla Firebird

VERIFIED FIXED

Status

()

bugzilla.mozilla.org
Administration
VERIFIED FIXED
15 years ago
4 years ago

People

(Reporter: Steffen Wilberg, Assigned: Hixie (not reading bugmail))

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030513 Mozilla Firebird/0.6

Bugzilla still displays Phoenix instead of Mozilla Firebird on this page.

Reproducible: Always

Steps to Reproduce:
1. Browse to http://bugzilla.mozilla.org/enter_bug.cgi?format=guided


Actual Results:  
Phoenix is displayed.

Expected Results:  
Mozilla Firebird should be displayed instead.

Firebird 0.6 will attract quite a few newbies. Some of them might want to submit
bugs. Don't confuse them with the former name they might not be aware of.

The description next to it should also be replaced to something like that:
"Mozilla Firebird is the new fast und highly customizable standalone browser
that will replace the Mozilla browser component. Bugzilla continues to use the
former project name Phoenix in its database."

Comment 1

15 years ago
I think this should have been filed under Product: Bugzilla and yeah I agree
entry should be changed so it doesn't confuse new users trying to file a bug.

Comment 2

15 years ago
Moving over to mozilla.org product (bugzilla product is not the right choice.
See http://bugzilla.mozilla.org/describecomponents.cgi for an explanation) and
confirming.
Assignee: blaker → ian
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: General → Bugzilla: Keywords & Components
Ever confirmed: true
OS: Windows XP → All
Product: Phoenix → mozilla.org
QA Contact: asa → timeless
Hardware: PC → All
Summary: Bugzilla displays Phoenix instead of Mozilla Firebird → Phoenix product should be changed to Mozilla Firebird
Version: unspecified → other

Comment 3

15 years ago
We don't make changes to bugzilla components just because end users want them

Ben: this is the kind of bug you should have filed.

that said. according to despot, hyatt owns mozilla/browser which is called
Phoenix and the project page is Phoenix and the description says Phoenix.

Also note that there is documentation on the website pointing to a bugzilla
product named phoenix, and making this change without changing the related
links will result in lots of bugs complaining about them being broken.
Phoenix users have shown that they will file such bugs when simple things break
(ref: useragent horkage).

For the last Bugzilla product rename (Chimera=>Camino),
I believe myk created some redirection code.

Further, the branding page talks about firebird just being a codename and not
for end user use. Blizzard: did i misread that page?

We don't have a Seamonkey product in bugzilla, so why should we have a Firebird
product?

Things to consider:
Renaming 'Browser' to 'Mozilla' or 'Gecko' and 'Phoenix' to 'Browser'.

Comment 4

15 years ago
We don't need to change anything here just yet. I'm working on a larger plan to
get seamonkey xpfe out of browser into its own product and rename browser to
describe the core services like gecko, necko, etc. that will live there. I think
that the phoenix product will become "Browser" but I haven't gotten it all
figured out just yet. Please don't make any changes for this bug just yet.
(Assignee)

Comment 5

15 years ago
> Renaming 'Browser' to 'Mozilla' or 'Gecko' and 'Phoenix' to 'Browser'.

This is my current long term (upcoming months) plan. Browser would contain core
Gecko and Gecko embedding bugs, and Phoenix would be the equivalent of MailNews,
containing stuff that is specific to the Firebird product. There would also be
additional products for the Editor UI (separate from the embeddable editor
component -- this would be equivalent to the current Editor: Composer and
Editor: CSS Editor components) and possibly a general product for things like
ChatZilla and Mozilla-hosted extensions.

Browser components Bookmarks, Download Manager, Help, History: Global (partly),
JavaScript Console, Keyboard: *, Page Info, Password Manager, Preferences,
Search (partly), Sidebar, possibly Tabbed Browser, URL Bar, and XP Apps: GUI
Features, and all their bugs would be moved to a separate product, "Seamonkey"
or some such.
(Assignee)

Comment 6

15 years ago
> Browser would contain core Gecko and Gecko embedding bugs, and Phoenix would be
> the equivalent of MailNews, [...]

Just to clarify, Browser and Phoenix would also be renamed appropriately.
(Reporter)

Comment 7

15 years ago
This is really a very good long-term concept.

However, this bug was meant to be short-term. I didn't mean to change "Phoenix"
in the bugzilla database to "Firebird" because I knew that this would be far
from simple.

What I meant was to change the text on this single web page from "Phoenix" to
"Mozilla Firebird" or just "Firebird" and alter the description next to it.
Don't change the link, don't change anything in the database. Just have a
description that states that bugzilla continues to use the former project name
Phoenix in its database.

Users could then find "Firebird" on this page and notice that it is referred to
as "Phoenix" in bugzilla.

Another option would be to change the description only. I mean, there should be
a reference to Firebird just somewhere.
(Reporter)

Comment 8

15 years ago
The description has changed to "Phoenix: Now known as Mozilla Firebird...".
That's a start.
(Assignee)

Comment 9

14 years ago
done.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Comment 10

14 years ago
You shouldn't have done that.
This broke http://bugzilla.mozilla.org/describecomponents.cgi among other places:

Bugzilla Component Descriptions
	  	Please specify the product whose components you want described.

Client Software
	
Browser: 	 (most common) Mozilla Browser project, including Composer and the
Mozilla platform. This is not the place for problems with third party products.
MailNews: 	 The Mozilla Mail/News project, including the Address Book component
(more info)
Camino: 	 Camino (formerly known as Chimera) is a native Mac OS X browser-only
project. For more info, see http://mozilla.org/projects/camino/.
Phoenix:
Calendar: 	 The Mozilla Calendar project (more info)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This was fixed a while back.  The issues in comment #10 were resolved.
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

14 years ago
.
Status: RESOLVED → VERIFIED
Component: Bugzilla: Keywords & Components → Administration
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.