Caret doesn't display after newline properly elements with white-space set to pre

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
16 years ago
15 years ago

People

(Reporter: ronoc, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

A caret placed right after a newline in an element with a white-space setting of
pre will display right after the newline rather than at the first position on
the next line. This is a rendering bug AND THERE IS NO WORKAROUND as far as I
can see.

Reproducible: Always

Steps to Reproduce:
See http://www.playsophy.com/edom/bugzillas/pre/precaretbug.html and follow the
steps it contains.

Actual Results:  
See test page.

Expected Results:  
Caret should appear on a line after a newline and not on the newline's line

Comment 1

15 years ago
Bug Day: 1-13-2004

As of Mozilla 1.6b this no longer seems to be a bug.  If you feel it's still
relevant please let us know.
This bug can't be reproduced on recent builds.  Marking WORKSFORME.  If you feel
that this is still an issue, you can reopen the bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.