A GIF image cannot be displayed

RESOLVED FIXED

Status

()

RESOLVED FIXED
16 years ago
15 years ago

People

(Reporter: johnk, Assigned: tor)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030507

When viewing the GIF image, I instead get the following text:

The image "http://zhongwen.com/s/y508-1.gif" cannot be displayed because it
contains errors.


Reproducible: Always

Steps to Reproduce:
Open the the URL "http://zhongwen.com/s/y508-1.gif".
Actual Results:  
The text:

The image "http://zhongwen.com/s/y508-1.gif" cannot be displayed because it
contains errors.

appears

Expected Results:  
Internet Explorer is able to view the image.
->ImageLib
Assignee: other → jdunn
Component: Layout → ImageLib
QA Contact: ian → tpreston

Comment 2

16 years ago
Opera and IrfanView are able to open and display, ULead GIF Animator doesn't
support this format and Adobe PhotoShop 7 hangs while opening.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
gif decoder is failing in GIF2.cpp, line 365

      /* Check for a code not defined in the dictionary yet. */
      if (code > avail)
        return -1;

code is 0x500
and avail is 0x452
(Assignee)

Comment 4

15 years ago
Created attachment 130364 [details] [diff] [review]
tweak lzw decoder

Looking through a number of other gif decoder implementations (gimp,
gtk+, ImageMagick), we seem to be interpreting a code that isn't in
the dictionary differently.  We were treating it as an error, while
others use it as the firstcar condition.  (Hunk 1)

Patch also removes some redundant code2 logic and changes the loop
condition of the while loop to match other decoders.  (Hunk 2&3)
(Assignee)

Comment 5

15 years ago
Reassign -> tor
Assignee: jdunn → tor

Comment 6

15 years ago
I have the same problem, check out my site www.galaxyinteractive.net, it works
in i.e. and on my linux moz browser 1.2.1(gecko20030225)
(Assignee)

Updated

15 years ago
Attachment #130364 - Flags: review?(paper)
(Assignee)

Comment 7

15 years ago
*** Bug 222950 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
Comment on attachment 130364 [details] [diff] [review]
tweak lzw decoder

r=paper
Attachment #130364 - Flags: review?(paper) → review+
(Assignee)

Updated

15 years ago
Attachment #130364 - Flags: superreview?(bryner)
Attachment #130364 - Flags: superreview?(bryner) → superreview+
(Assignee)

Updated

15 years ago
Attachment #130364 - Flags: approval1.6a?

Comment 9

15 years ago
Comment on attachment 130364 [details] [diff] [review]
tweak lzw decoder

a=asa (on behalf of drivers) for checkin to 1.6alpha
Attachment #130364 - Flags: approval1.6a? → approval1.6a+
(Assignee)

Comment 10

15 years ago
Checked in.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Depends on: 229652
You need to log in before you can comment on or make changes to this bug.