If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

firebird (phoenix) build fails at make-jars.pl from ActiveState perl parameter handling

VERIFIED DUPLICATE of bug 175692

Status

()

Firefox
Build Config
VERIFIED DUPLICATE of bug 175692
15 years ago
11 years ago

People

(Reporter: Steve Krulewitz, Assigned: Brian Ryner (not reading))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030511 Mozilla Firebird/0.6

Building Firebird (Phoenix) on Windows 2000 with ActiveState perl fails at
make-jars.pl:

make[5]: Entering directory
`/cygdrive/c/mozilla/toolkit/components/console'
sh /cygdrive/c/mozilla/build/cygwin-wrapper c:/moztools/bin/nsinstall
-m 755 jsconsole-clhandler.js ../../../dist/bin/components
+++ making chrome c:/mozilla/toolkit/components/console =>
../../../dist/bin/chrome/toolkit.jar
The system cannot find the file specified.
Preprocessing of content/console.js failed: 1 'c:\Perl\bin\perl.exe
c:/mozilla/config/preprocessor.pl -DOSTYPE="WINNT5.0" -DOSARCH="WINNT"
-DX_DISPLAY_MISSING=1 -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1
-DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DWINVER=0x400
-DSTDC_HEADERS=1 -DNEW_H=\<new\> -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1
-D_X86_=1 -DD_INO=d_ino -DMOZ_DEFAULT_TOOLKIT="windows"
-DMOZ_PHOENIX=1 -DMOZ_XUL_APP=1 -DMOZ_ENABLE_COREXFONTS=1 -DOJI=1
-DIBMBIDI=1 -DACCESSIBILITY=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1
-DMOZ_MATHML=1 -DMOZ_LOGGING=1 -DMOZ_USER_DIR=".mozilla"
-DCPP_THROW_NEW=throw\(\) -DMOZ_XUL=1 -DMOZ_PROFILESHARING=1
-DMOZ_DLL_SUFFIX=".dll" -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1
-DNS_PRINTING=1-DMOZILLA_VERSION="1.4b" content/console.js >
../../../dist/bin/chrome/toolkit/content/global/console.js' at
c:/mozilla/config/make-jars.pl line 391, <STDIN> line 2.

It appears that ActiveState does not like the escaping used in -DNEW_H=\<new\>.
 I inserted a few regexps in make-jars.pl before the system call to
preprocessor.pl to change the option to -DNEW_H="<new>" (as well as change
-DCPP_THROW_NEW=throw\(\) to -DCPP_THROW_NEW=throw()) and the build worked fine.


Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

15 years ago
I should add that I'm not sure if changing it to -DNEW_H="<new>" is the correct
solution, it could be "-DNEW_H=<new>" -- I didn't dig that deep.

Comment 2

14 years ago

*** This bug has been marked as a duplicate of 175692 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Comment 3

14 years ago
Mass-verifying. Sorry for bugspam.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.